Scaler EQ V1.1 Crashing Ableton 12

Every time i try starting scaler EQ Ableton 12 crashes, I had no problems with the old v1.0. Any suggestions?

Hi @wlugo312 Can you please give us some more info as we use Scaler EQ 1.1 all the time.
Mac, Windows? Machine type? Steps to reproduce the crash?

My apologies Windows 10, 64, 32 gigs of ram.
I just did some investigating myself I uninstalled VST.3 and loaded VST.2 64 and it seems to be working. So the problem is definitely with the VST 3 version of the plug-in.

Thank you

Thank you. @Tristan Can you please check this on your end?

Hi folks. I’m having no issues with either VST2 or VST3 versions of Scaler EQ 1.1 in Ableton Live 12 on Windows 11. Sorry @wlugo312 I’m not sure what could be causing the crash you’re experiencing. I can only recommend a complete uninstall/reinstall of Scaler EQ and making sure there are no Windows OS updates to install.

Have you checked this thread here where someone was having an issue on Win 10?

I’m having the same problem in Ableton 12 as well. I’m on a MBP M2, Sonoma 14.2.1 and Scaler 1.1.0. I’ve only tried the VST3 version. It’s incredibly disappointing since I just bought the eq.

Hi @RMBL welcome to the forum. This issue in this thread relates to Windows, we haven’t had any users reporting issues on a Mac. I am running the same setup as you. Could you give some more info as to what is leading to the crash? Have you tried VST and AU to see whether you have any luck?

Thank you for the reply, @davide. Scaler kept crashing sessions as soon as i would go to open the plugin. However, after further test, if I start Ableton from a blank session (instead of my template) Scaler eq works fine. I’ve tried to open all the plugins I use in my template to recreate the issue, but have not been able to. It still only happens in songs that I have already started. I’m not sure what this could mean.

I can confirm 100% Sclaer EQ has knackered our mix, everytime Ableton 12 (Current Public Release) and (Beta 12.0.5b3) on:

  • Mac OSX 14.4 (23E214)
  • Macbook Pro 14" 2021 M1 Max
  • Running in Rosetta
  • Memory 64 GB

Initial issue was loading the plugin to any track Midi or Audio, Ableton would crash.

Issues has now changed to not loading the .asl file, so we can’t even open the track which is acutally a pre-master.

Rollback to previous backup and ditch Scaler EQ until fixed.


Translated Report (Full Report Below)

Process: Live [3530]
Path: /Applications/Ableton Live 12
Version: 12.0.5b3 (2024-04-03_f915bbc534) (12.0.5b3 (2024-04-03_f915bbc534))
Code Type: ARM-64 (Native)
Parent Process: launchd [1]
User ID: 501

Date/Time: 2024-04-06 04:29:02.1271 +0100
OS Version: macOS 14.4 (23E214)
Report Version: 12
Anonymous UUID: D7884B35-1C7E-5B23-D73F-539B6B6278E4

Time Awake Since Boot: 4400 seconds

System Integrity Protection: enabled

Crashed Thread: 0 MainThread Dispatch queue:

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000040040828
Exception Codes: 0x0000000000000001, 0x0000000040040828

Termination Reason: Namespace SIGNAL, Code 11 Segmentation fault: 11
Terminating Process: exc handler [3530]

VM Region Info: 0x40040828 is not in any region. Bytes before following region: 3232397272
__TEXT 100ae8000-105b60000 [ 80.5M] r-x/r-x SM=COW /Applications/Ableton Live 12

Thread 0 Crashed:: MainThread Dispatch queue:
0 Scaler EQ 0x4686811a4 juce::ValueTree::getOrCreateChildWithName(juce::Identifier const&, juce::UndoManager*) + 24
1 Scaler EQ 0x4689d1c2c ScalerEQAudioProcessor::saveCurrentScalesToSlot(int) + 168
2 Scaler EQ 0x4689e39e0 std::__1::__function::__func<ScalerEQAudioProcessor::ScalerEQAudioProcessor()::$_19::operator()(float) const::‘lambda’(), std::__1::allocator<ScalerEQAudioProcessor::ScalerEQAudioProcessor()::$_19::operator()(float) const::‘lambda’()>, void ()>::operator()() + 56
3 Scaler EQ 0x4686d2a20 juce::MessageQueue::deliverNextMessage() + 60
4 Scaler EQ 0x4686d29a4 juce::MessageQueue::runLoopCallback() + 32
6 CoreFoundation 0x1872d9e44 __CFRunLoopDoSource0 + 176
7 CoreFoundation 0x1872d9c14 __CFRunLoopDoSources0 + 340
8 CoreFoundation 0x1872d87a0 __CFRunLoopRun + 828
9 CoreFoundation 0x1872d7e0c CFRunLoopRunSpecific + 608
10 HIToolbox 0x191a73000 RunCurrentEventLoopInMode + 292
11 HIToolbox 0x191a72c90 ReceiveNextEventCommon + 220
12 HIToolbox 0x191a72b94 _BlockUntilNextEventMatchingListInModeWithFilter + 76
13 AppKit 0x18ab30970 _DPSNextEvent + 660
14 AppKit 0x18b322dec -[NSApplication(NSEventRouting) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 700
15 AppKit 0x18ab23cb8 -[NSApplication run] + 476
16 Live 0x101cf5244 0x100ae8000 + 18928196
17 dyld 0x186e720e0 start + 2360

Welcome to the forum @MMFF I’m passing this on to our developers but we can’t recreate your issue on a similar setup so a few Q’s for you if you have the time and are inclined:

Does this happen when loading natively (outside of Rosetta)?
Does Scaler EQ 1.1 open and function normally when opening it in a new project (no in a project where are previous instance of Scaler EQ exists).?

It seems two Mac users here have had an issue opening an old session with a pre-existing Scaler EQ 1.0 instance. The main issue in this thread relates to windows users and has been fixed with a Scaler EQ 1.1.1 update currently being uploaded to Plugin Boutique