Scaler freezes on opening

If I build a project with Scaler 2, it typically works fine. But if I save my project with the Scaler window open, and then close the project, when I go to re-open that project, the Scaler window freezes after partially opening, and then Mixcraft has to be closed and restarted.

After that, I have to disable Scaler, and try to reopen the project, and sometimes start another project, copying the components over. Once the crashing has occurred, even if I later save the project with the Scaler windows closed, a crash still occurs when I try to reopen the Scaler windows.

This is spoiling my appreciation for an otherwise great product. Is there anything to be done about this?

Glenn

I am using Mixcraft 9, Windows 10, 64 bits.

Maybe try this…
You can disable OpenGL Rendering from the ScalerSettings application:

  • Press the Windows key to open the search and type “ ScalerSettings

  • Go to the Help page and click “Turn OFF OpenGL”:

Thanks for the suggestion. Can you give me an idea why you suggest this? I gather this is not a general problem anybody else is having. Has this worked for other freezes?

Just trying to get smart!

I suggest it because this solution has fixed a few issues that are quite common - black or blank gui, crashes. Not sure it is related in your case but it has worked on these other things. Worked for me on freezes and crashes in Cubase.

Jamieh, that seems to have done it. At least so far. Thanks so much for helping!

Glenn