Scaler Midi FX cannot load in Logic for iPad

Comes up with a “contact vendor” message… V2.7


Thanks for pointing out @zzrwood We haven’t had a chance to check it out yet as we were not involved in any pre-release beta with Apple. Will have a look today and see if there are any adjustments we can make. We have a 2.8 version ready for iPad so let’s see what we can do for this version @Ed1 @james

1 Like

FYI - its all Scaler’s AUv3s, not just Midi FX…

1 Like

Yep got it, same behaviour here. Devs on it now lets see if they can find a solution - will report back.

Glad it’s notp\ only me.

This has been fixed and will be available as part of the 2.8 update on the App Store 25th of May (today here in Australia). Scaler MIDI FX, Instrument and Audio all working. The GUI resizing is not responding as it should within the Logic Pro iPad shell but we will get working on making the resizing and Scaler iPad UX a priority. Works great for now but not ideal.


Thanks for the quick responses, but Im afraid that 2.8 has only partially fixed it for me.
I’m running an iPad Air 4 and the interface doesn’t show the instrument panel:

If I turn off the default “mini plug-in tiles” in the menu it provides a little more vertical real estate, but still not enough to display instrument panel…

What do you mean by the instrument panel? You mean Scalers internal instrument menu? As far as all the scaler features they are accessible on our end, you can also go vertical on the iPad which can help. Let me know what I am missing?

Don’t you have MIDI FX loaded? That has no internal instruments as far as I recall.

[ADDENDUM] I see what you are talking about now! That’s not good.

1 Like

Sorry Davide - I thought the screen shots would have made it clear.
The piano keyboard panel is missing from the top of the plug-in - and in its place is a message that “the instrument panel is missing” and to resize to make the panel bigger. But it is already at maximum size…

Hi @zzrwood,

Obviously with the introduction of Logic for iPad there appears to be the need for us to restructure the UI to work seamlessly with Logic’s interface. This is a priority on our end for development.
I think for the time being the workaround might be to work with your iPad in vertical orientation as this will allow access to all Scaler features and the Logic keyboard at the same time (if necessary).

Here you can see that all features are accessible in vertical orientation.

Thanks, but I think you misunderstood my point.
It is not the Logic keyboard I am concerned about, but the Scaler keyboard that is missing from the top.
While it may work in portrait I use the pad with the Apple Magic Keyboard so it is always in landscape.
It’s not a big deal, I can work around it, just thought I needed to be clear about what the issue is with the Scaler plug-in not scaling appropriately - sorry about the pun :grin:

@zzrwood Your point was conveyed appropriately and, Logic keyboard aside, you can see in the above screenshots that working in vertical is currently the only workaround to access the Scaler keyboard. We realize this is less than ideal but I can assure you that this is at the top of our priorities to address asap.

Thanks, I love Scaler and do my best to sing its praises from the rooftops! :+1:
I’m a Logic user on Mac (with Scaler) so very excited about Logic and Scaler on the iPad going forward.

Came here thinking there’d be all sorts of posts about Logic Pro for iPad, as MIDI FX have been a whole discussion before the DAW came out and Scaler is likely among the most popular ones (apart from Bram Bos’s Rozeta and Mozaic). Plus… we’ve got issues. Glad the team is working on those.

Had the same issue with 2.7… Since Scaler was the very first plugin I tried in Logic Pro, that felt particularly strange!

Of course, that loading bug was fixed with 2.8… though the display bug is quite distracting. (The UI rolls down really slowly when you expand the plugin.)

(Yes, this is a realtime screen capture on a fully-loaded M1 iPad Pro, 2TB/16GB.)

Then, there’s the matter of bringing the processed MIDI to a Logic Pro track. Sure, much of that is a problem with Logic Pro itself. At the same time, it makes for a cumbersome experience.
Basically, the easiest way (I’ve found) to get MIDI to a track is to long-press on the Scaler mini-plugin tile and select “Record MIDI to track here”

That does work. It’s just that you need to play the sequence in realtime, instead of dragging files around. (I was convinced that there would be a way to drag MIDI files in Logic Pro. Tried the obvious things, including Slide Over. Can’t find it.)
So, though it’s an issue specific to Logic Pro, it’d be really useful to have something in the UI to lead us to the proper solution.

At any rate… Logic Pro is such an obvious context for Scaler! More so than plugin hosts like Loopy Pro and AUM… at least until Loopy Pro gets MIDI loops. So it’d be neat to have something close to an optimal experience here. For instance, a mini-plugin tile which provides enough functionality to make it work. (It works well enough with 4Pockets’s Progressions that I can close the UI and just play, after tweaking a few things in a responsive GUI.)

So, wishing courage to the dev team. Apple didn’t give you the type of advanced notice which would have allowed you to fix things before the launch.

1 Like

I am also facing the issue of scaler resizing very slowly within Logic Pro for the iPad. Any updates if this is going to be fixed soon? Thanks!

Devs are aware and are working on it.

1 Like

Amazing, thank you and looking forward to it

I’ve found a workaround for the Scaler keyboard not appearing in Logic on my iPad Air 4… All I had to do was buy a new 11” iPad Pro and set Display Zoom to “More Space” in settings. :+1::grin:

1 Like