Scaler not loading in Ableton Live 10.1

64 bit vst2 Scaler will not load in Live 10.1. The message that it is disabled and not compatible with Live pops up. Trying to load the VST3 version crashes live. It works fine in FL Studio 20.1.

Hi @Clarksil

thanks for reporting your issue,

this is quite strange, are you using Windows or Mac ?

Windows 10 16 gb ram, i5. Seems most or all other plugins work.

Actually intel core i7

Works Fine in Reason 10 as well.

Have you tried your computer after installing?

It seems quite strange that it is working everywhere but in Live.

Tried rebooting and still not working. Installed v1.7 and it would open but not allow me to register. Very frustrating, since Ableton is my main DAW. I would like to go back to 1.7 for now since I really started using Scaler in the past month and have spent a lot of hours with it. Not sure at this point. Cthulu is terrible, and I really don’t want to spend the money on Captain Chords. Can you at least help me get 1.7 registered again? Have you heard of anyone else having a problem Ableton?

Not at this stage, and I am able to run it normally here in Live.

The fact that you can’t seem to register it makes me think that Windows isn’t looking for your license file in the correct place.

When you add your licence file, Scaler tries to move it into your application data folder located under:

“C:\Users\[username]\AppData\Roaming\Plugin Boutique\Scaler\scaler.license”

You can check if it has been moved in there.
It can happen that your document folder is moved to another location due to a Windows restoration for example.

Thanks for your help Ed. I will still try to fix it today. Maybe if I completely uninstall and install it will work.
Weird that you have it working there. Are you using 10.1?

So I again tried uninstalling and reinstalling V8.1 again today with no luck. Abelton 10.1 still disables it ans says it’s not compatible. Every other plugin I have runs in Ableton! WTF!! Uninstalled and, reinstalled 7.1, and it won’t take my license file. At wits end at this point!!

It works in everything but Ableton???

Well well well I finally got it to work Ed!!! Instead of putting it a separate folder, I installed it in the general VST folder, i.e. I have a separate folder for Plugin Boutique in my VST plugins folder, but apparently Scaler doesn’t like that!! Thanks for all your help Ed!! Now I can use this great program in my favorite DAW!!!

1 Like

I have the same issue with Ableton Live 9 so I will give this a try-thanks!

I am experiencing the same error. Can I ask whether, in the end you loaded Scaler into the Steinberg VST default folders to make it work? I have tried a number of levels within my custom VST folder structure & have the same problem each time.