Scaler not sending MIDI to VSTs - Ableton

Hi there,

I’ve read through all the FAQs and troubleshooting documents and can’t figure this out. I’ve set up routing MIDI from Scaler 2 to a VST in Ableton using the official setup guide from here: Scaler 2 | VSTi Routing in Ableton Live | Quick Tip Tutorial - YouTube but I’m not getting any notes to pass through.

If I play notes on my MIDI keyboard, they pass through Scaler into the VST just fine. When I try to play chord progressions inside Scaler (like in Scaler’s “Song” tab) the notes do not pass through.

I’m running in demo mode, so I would totally understand if this is a limitation from the demo. I just don’t see it documented anywhere that this is a limitation in demo mode so I want to make sure.

Welcome @j_silverton
Not a demo limitation and should be working fine, can you detail what platform, OS, Ableton version you are running to help someone reply.

OK thanks. Ableton 11.0.12, MacOS 10.13.6. The plugin seems to work fine otherwise. Is there a setting that you need to check in Scaler 2 to enable MIDI output?

This is what your set up should look like. Mine is exactly the same system version, etc. as yours. Make sure you are using either the VST2 or VST3 Scaler. The Mac AU won’t work passing MIDI as the AU spec doesn’t let it.
The Monitor should be set to IN on the Instrument track and controller set to Scaler MIDI in and the one below it as shown. Make sure the MIDI Bind is on in Scaler which is the button on the right. It will blink Blue when activated…

Thanks for your reply. I double-checked this setup, and tried it with MIDI Bind selected, but got the same result. When I use MIDI Bind, it just passes the original note through (rather than turning it into a chord). And when I click on the chords within Scaler 2, I get no notes.

Here’s a screen capture video so you can review my setup: Scaler Demo.mov - Google Drive

Bump. Is the video working?

Unless it’s a video of an arrow going round in a circle, no. :slightly_smiling_face:

i can see the video… (watching on iPad)

looks like your second track has different MIDI routing than what Jamie’s screenshot suggested…

Your input to the instrument track should also say Scaler where it says Post FX in yours. It won’t work the way you have it.

Hi @j_silverton

It should look something like this:

image

This option isn’t available when Scaler 2 is loaded as Audio Unit (AU)

This option is available when Scaler 2 is loaded as VST3 or VST2.
Then make sure to arm or enable the monitoring as usual Ableton routing.

Hope that helps,
Cheers,
Paul

1 Like

Thanks, this was the issue! In Ableton, I’m used to selecting “Post FX” for MIDI plugins like Arpeggiators, Pitch devices etc because you want to capture the MIDI after it has been processed through the plugin. Thanks for your help.

1 Like