Scaler not triggering MIDI/Software instrument in Logic X


I have just installed the update Scaler 2.2 and now when I use Scaler as a MIDI device within Logic Pro it doesn’t trigger the software instrument. When I turn the Scaler Device off the software instrument is triggered by my MIDI keyboard; however, when I turn Scaler back on nothing is triggered. Does anyone know how to solve this? I have attached a screenshot below.


Hi @ryanm

that’s interesting, we use Logic a lot within the dev team and don’t have this issue on our machines. We provide a MIDI FX (ScalerControl) and a virtual instrument version (Scaler), does the instrument version work normally on your machine?

Would you also mind sharing a bit more info on your hardware and the version of macOS and Logic you are running? This will help us diagnose the issue.


I just tried this on my Mac and it works fine. Can you let us know a bit more about your set up.

Always reboot my Mac after updating plugs, resolves 99% of issues for me.

Hi Ed,

Thanks for your response, I appreciate it. Scaler 2.1.2 was working absolutely fine (both MIDI and as a virtual instrument); however, after installing 2.2 it has caused some issues. I have tried to reinstall 2.1.2 but the same issues are still there.

It doesn’t seem to be outputting MIDI data as a MIDI FX plugin, then the software instrument isn’t correctly receiving MIDI data as it seems to lag. It does work but I have to use the virtual keyboard and press the keys with my mouse which is strange. I also use it with Ableton and it works fine, as I am using the VST3 to trigger a second MIDI channel.

I am using the new M1 laptop with Big Sur, the Logic version is 10.6.1. (I’m guessing this is where the problem will be arising as I know a lot of plugins aren’t fully configured with the M1 chip yet).

Let me know if you need any further information,
kind regards

Hi @ryanm

I guess it could be an M1 issue, I can run Scaler 2 (the AU instrument) here on the M1 Macbook Air in Logic Pro, but ScalerControl 2 (the MIDI FX) does not pass the note through.

It seems the VST and VST3 version are OK as well in Ableton…not too sure what it is at this stage.
We will investigate a bit more and get back to you.

Thanks for the additional info,

Thanks Ed, appreciate the speedy response.

I can confirm that I am seeing the same thing with an m1 MacBook Pro 13 macOS 11.1 and Scaler 2.12 under Logic 10.6.1.

ScalerControl is receiving midi, but not passing it to software instruments on the same channel strip. If I disable scaler control, I can play the software instruments directly.

can you visit this post to vote in order to help fix this issue?