Scaler Plays Incorrect 1st Chord After KeySwitch in Pad View Across Midi Clips

When switching sections using Keyswitch, Scaler plays the first chord of the previous section, not the new section. The new section chord pad and the pad light at the far right both light correctly as though the switch has happened. After the first chord, all subsequent chords including the first chord in the new section are played correctly.

When I consolidate the midi clips, the behaviour is correct.

System and version info? What do you mean “consolidate the MIDI clips”?

Catalina 10.15.7 / Scaler 2.3.1

Consolidate is Live-speak for merge ‘n’ midi files into one.

So the other missing piece in this equation is you are using Scaler in Live 10 or 11?
I ask because I want to see if I can replicate this.

Bo,y have I been slack with the necessary detaisl! :upside_down_face:

Live 11.02 It looks like this update happened March 26. This project was started on April 1.

I can’t get that same behavior in mine. When I use the keyswitch on the pattern the first one plays as it should.
OS 10.13.6 though and Live 11 Scaler 2.3.1

Oh yes, I experience it a lot. It means you are a little bit late when pressing Keyswitch and Scaler kind of starts with 1st chord in current pattern and then catches up and moves to next pattern.
Better to be a tad early (or exactly on time of corse).

Does quantise playback help with this?

I’ll give you context but first a disclaimer :slight_smile: I consider Scaler Gods gift to humanity and the I see below unexpected behavior as a minute annoyance :rofl:.

The problem with green keyswitches only happens when, in Pad mode, looping is activated and pattern change is done manually.
Triggering pattern change using notes on Scaler track works as expected.

1st Problem
When (imperfect) human triggers pattern change (1 → 2) at the end of Pattern 1, if it’s done a bit late, Scaler will play 1st chord of Pattern 1 and then continue with chords 2, 3, 4 of Pattern 2. Second iteration of Pattern 2 will be of corse complete.

2nd Problem
If patterns have not equal number of chord blocks, another strange behavior happens when changing from “shorter” pattern to “longer” pattern. When changing at the end of Pattern 2 to Pattern 1, last chord of Pattern 1 will get played (and only then Scaler will start from chord 1).

Both patterns have the same length but different number of chords.

I mostly avoid those problems selecting all patterns at once and making Scaler play those sequentially.
Would be so great to have “trigger playback of pattern with green keys” option ie. pressing C would play Pattern 1 end to end, pressing D would do the same for Pattern 2.

It isnt late in this case. I learned the hard way back in early Scaler days. :slight_smile: The midi is quantized to the beat and I have reviewed it to a 1/512 note level to see if it was off a tiny bit. Plus, if it were late, it would still be late in the consolidated clip where it actually works as expected. Live does not adjust midi timing when consolidating midi clips. I am in the middle of a musical mentorship and have to get my homework done first. I will dig in a bit later in the week and see if I can recreate this.

Oh man… Looks like I misunderstood your post. Sorry @jeffreyk for hijacking your thread. I’ll be quiet as a church mouse now :slight_smile:

@davide I dug in further on this today.

  1. In Live I zoomed the clip in to 1/16k which is the furthest Live provides a measure of the grid. I quantized the notes. They look like they are right on the grid line. The initial keyswitch change is not recognized (to play the first pad correctly on the first pass).
  2. If I bring the note start in just a smidge - so 1/64,000 approx. in, the keyswitch functions properly.
  3. I duplicated the Scaler track that was not working and replaced Scaler with a Kontakt NI Guitar and then Strum. In both cases, the quantized midi note was recognized and initiated the keyswitch correctly. (I had to move the Strum note down an octave so to be consistent I tested the NI Guitar whose keyswitches operate in the same range as Scaler.)

Thanks for the feedback and testing, this is helpful. I will share with @Ed1 and the team.