Scaler Time Signature MIDI Drag and Drop

Hey,

Love the addition of additional time signature rhythms added in 2.8. Could it be possible to output the MIDI in the time signature of the rhythm instead of just defaulting to 4/4 when dragging into your DAW?

Have you set your DAW to the same time signature as the clip?

I have in Ableton. Still comes up as 4/4.

Did you change the beat in preferences of Scaler? Which time sig are you using?

6/8 was the signature used in Scaler and within my DAW

So under preferences>Beats you had it set to 6 beats? I’m not referring to the time signature of the expression you were using but the global beats.

I just did a quick test in Bitwig. I set Scaler Global beats to 6 and drag and dropped one of the 6/8 phrases to Bitwig also set for 6/8. The phrase matched exactly 2bars of 6/8. If I set global beats to 4 beats and D&D the same phrase, there is extra space at the end of the clip and the music is 2 bars of 4 beats so it is shorter. See photo.

In Ableton if the beats are set to 6 under Global beats the 2 bars of 6/8 will be correct but the end of the clip needs to be set to the last note ending. Ableton quirk by the looks of it.

1 Like

Yeah, that looks to be the case! Went through what you said and was still getting those odd issues. Super appreciate you walking through it with me!

HI guys

Looking at this post I think I have found a similar issue. I should start by stating that I vary rarely use 6/8 time: like most amateur untrained composers I tend to stick to 4/4/. However I have been experimenting with 6/8 to try to understand the issue and here are my results.

Test 1: to verify Scaler is outputting midi with the correct time signature of 3/4
Set Ableton Live time signature to 3/4
Set Scaler Chord Duration to 3
Load 1 block with C maj
Select Performance - Phrases -3/4 1 Phrase.
Capture Midi for 1 bar
Drag Output to new midi track

Result - 1 bar recorded - correct

Test 2: to verify Scaler is outputting midi with the correct time signature of 6/8
Set Ableton Live time signature to 6/8
Set Scaler Chord Duration to 6
Load 1 block with C maj
Select Performance - Phrases - 6/8 1 Phrase.
Capture Midi for 1 bar
Drag Output to new midi track

Result - 2 bars recorded - I think that this is an error and it should be 1 bar.

I then repeated these tests on Reaper and Cakewalk with the same results.

So to conclude, setting the DAW time signature to 6/8, and Scaler Chord Duration to 6 gives an output that appears to be twice as long as it should be.

I have attached the Scaler states from the Reaper tests together with the resulting midi files. If anyone can suggest why the midi file from the 6/8 is two bars long rather than one I would be grateful.

Test in 3/4 time
Scaler state: Reaper 34 test.xml (10.1 KB)
Midi output: Reaper 34 Test.mid (263 Bytes)

Test in 6/8 time
Scaler state: Reaper 68 test.xml (10.1 KB)
Midi output: Reaper 68 Test.mid (415 Bytes)

@ed66 As I clearly stated those 6/8 phrases are 2 bars long. If I take your Scaler state and use it in Live I get the same odd import, meaning Live, even though set to the right time sig, sees the same sig of the clip as 4/4. If I manually correct the clip then Live displays it right. Even importing your MIDI clips from Reaper to Live has the same incorrect results. So Live has this odd quirk no doubt because it see clips as 4/4 until corrected.
Bitwig and Cubase see them correctly and maybe reaper as well. So Scaler is exporting correctly. Live is the odd man out.



Now in Bitwig everything is correct. 3/4 is right and 6/8 is right/

I appreciate that the clip may be 2 bars long, and I think I have found the issue. It is the combination of time signatures and the Chord Duration setting.

The phrase 6/8 1 Phrase is [obviously] in 6/8 time, and music in 6/8 time is divided into two sets of three quavers in a bar. Now to only capture the first bar of the phrase the Chord Duration setting has to be 3 beats I found this by experimenting). This implies that each beat is = 2 quavers (= 1 crotchet). Technically I think that this may be wrong (any music theoreticians who can help?) as the accent, I believe, should be on the 1st and 4th notes in the bar in 6/8 music.

Can someone clarify this for me as I still believe that there are 6 beats in a bar of 6/8 music and 12 beats (accents on 1, 4 and 8) in 12/8 music?

For practical purposes in Scaler I will always divide the time signature into crotchets to apply the Chord Duration setting.

BTW if you try the Scaler State below you should get a midi clip that is two beats long although the actual performance is 4 beats. This is because I have set the Chord Duration to 2 beats.

Reaper 24 Test.xml (10.0 KB)

I never use midi capture only D&D. I often set my durations per chord in edit mode to match film cues. Much more valuable then MIDI capture for me but it makes sense the duration of MIDI capture relies on the Global Beat duration.
6/8 time is very familiar to me since I played jigs in a band that performed french and Irish music. Accents on the 1 and 4 of 2 sets of triples = ONE two three FOUR five six. As you say

I’m not sure what you mean here. Accents are on 1 and 4 with 2 sets of 3 beats or really 1 set of 6 beats depending on the piece.

This is 6/8 as jig time
image
And this is it in a song

I agree with you here.

My point is that in Scaler when I was experimenting with the 6/8 phrase (which has a length of 2 bars) I was expecting to only capture 1 bar (half the phrase) by setting the Chord Duration to 6 beats, but this captured 2 bars - the whole phrase. Hence I was confused and confounded.

Well here is another conundrum - 6/8 Phrase 2 is 4 bars long. I cannot capture the whole thing by D&D as with it set to 6 beats it only captures 2 bars. There is no 12 beat setting and there should be.
[ADDENDUM] I can go to Edit and change the performance timing to X2 and that works just fine.

But I think we still need 12 beat under Global if we keep things the way they are. Maybe the Devs will rethink how Global works in the future.

1 Like

I do see what you mean now. It seems Scaler must think in terms of quarter notes for duration. Therefore
6 quarter notes for 6/8 time would be 2 bars of 6/8. But with further testing it gets confusing as to what is really going on. Maybe if I get time I’ll test further but this makes thinking in the other time sigs… interesting.

Hey folks. Some interesting discussion here. For clarity, the beats which Scaler uses for chord durations are 1/4 notes or crotchets. So if working in 6/8 time signature, a 3 beat chord duration would be one bar.

This is why there are new 7/4 and 9/4 Rhythms as opposed to 7/8 and 9/8 Rhythms, to work with 7 and 9 beat chord durations. They do however work well when played for half their length, which you can do via the EDIT page with a x 0.5 duration value, effectively turning them into 7/8 and 9/8 Rhythms.

Regarding the original post, it does appear that patterns dragged into Ableton Live always default to 4/4 time signature, however the clip will be the correct length and will still play correctly. It’s just displayed over a 4/4 grid.

This doesn’t seem to be a problem in other DAWs like Logic where MIDI regions always follow the project’s time signature. In Live, Clips are more their own entity with unique properties.

This may not be an easy fix. As I understand Scaler doesn’t explicitly specify an internal time signature, it’s more generally about chord/pattern duration. But it is something to think about going forward and possibly implement in the future. Hope this helps!

3 Likes

Hi @Tristan
Thanks for clarifying this.