Scaler window not full screen

hey guys

when i first loaded scaler 2 into abelton it would load the plugin fine with it being a full screen window - now when i load scaler in ableton (after scaler 2 crashed it) it doesnt load the plugin screen full window :frowning:

i have attached this image

Hi @barnett71 and welcome,
is this happening with the VST3 version ?

thanks for the reply

Yes I have tried it with both VST/VST3 - The mouse also doesnt point in the right place so i cant chnage anything either

ok, could you please provide us your OS version ?
thanks for reporting,

I am on windows 10 and using ableton 10

thank you

Hi there, just adding my voice into this conversation to say I’m experiencing the same issue as well. Both the VST2 & VST3 versions don’t meet the window and so any button selections are out of sync. I’m also on Windows 10, on Ableton Live 10 Suite.

I love Scaler so I was pumped to use version 2! Hopefully this is something that can be resolved.

me too mutezero - the weird thing is when i first loaded it, it worked fine before my ableton crashed and now its not working proper

@mutezero and @barnett71 we are working on it, in the meanwhile as a workaround could you please try use a plugin view size not greater than 1000 x 700 and if your host is again downsizing it, please come back.
Hope that “helps”, we will keep you posted about the fix,

do i change this within abelton or scaler?

Directly from inside Scaler 2 go to Settings > PREFERENCES > VIEW SIZE

select 1000 x 700 and SET AS DEFAULT

this is a perfect workaround for the time being thank you for such a quick response :slight_smile:

You are welcome, but please come back if any problem occurs. Cheers, Paul

ok so when you initially set it to that size its fine, but when you go back into scaler2 it increases the size each time to the point where its so zoomed in you can find preferences

Still not working for me as well I’m afraid!

also when i load 2 other plugins the black border is on them aswell. I have re-installed ableton 10 without scaler 2 and the other plugins are fine until i install scaler

any progress on this guys? I have to un-install scaler for now until a fix is released as its messing up my other plugins

Hi @barnett71,

we are working on it, could you please give us some more information about your setup and particularly about your display resolution and any HiDPI or zooming configuration you may have setup, also are you using dual or single display ? Is your windows 10 up to date ?



PC SPECS - i5 8600k, 32gig ram, 1080ti gfx card, 4tb ssd, windows 10 (up to date)
MONITOR - 1 x Dell S2716DG 27 Inch 1440p monitor
ABLETON - Version 10.1.14 (HIDPI mode - ON - UI SCALE 110%)

Thanks for the specs.

@barnett71 @luapmartin I think I’ve managed to figure out what the issue is. It seems that you need to have Window’s Display settings changed so that the ‘Change the size of text, apps and other items’ amounts are at 100% instead of the ‘recommended’ 125%. It seems that apps like Scaler and Ozone 9 don’t scale right with Windows’ display settings.

It’s a slightly frustrating workaround but it works now!

1 Like