Scaler window not full screen

also when i load 2 other plugins the black border is on them aswell. I have re-installed ableton 10 without scaler 2 and the other plugins are fine until i install scaler

any progress on this guys? I have to un-install scaler for now until a fix is released as its messing up my other plugins

Hi @barnett71,

we are working on it, could you please give us some more information about your setup and particularly about your display resolution and any HiDPI or zooming configuration you may have setup, also are you using dual or single display ? Is your windows 10 up to date ?



PC SPECS - i5 8600k, 32gig ram, 1080ti gfx card, 4tb ssd, windows 10 (up to date)
MONITOR - 1 x Dell S2716DG 27 Inch 1440p monitor
ABLETON - Version 10.1.14 (HIDPI mode - ON - UI SCALE 110%)

Thanks for the specs.

@barnett71 @luapmartin I think I’ve managed to figure out what the issue is. It seems that you need to have Window’s Display settings changed so that the ‘Change the size of text, apps and other items’ amounts are at 100% instead of the ‘recommended’ 125%. It seems that apps like Scaler and Ozone 9 don’t scale right with Windows’ display settings.

It’s a slightly frustrating workaround but it works now!

1 Like

Hi @mutezero,
thanks for your message, note that some DAW allow you to disable the interface scaling inside of them.
For instance Ableton offer a Zoom display that can compensate your OS 100% by zooming Ableton UI.

Bitwig offer you the ability to control plugin DPI resolution scaling.

Etc. those allow you to counterbalance this workaround at DAW level hopefully,

1 Like

that will work for 1080p monitor but not for my 1440p - If I set it to 100% everything is far too small to read I have to have mine set to 150%

any update on this guys?

no reply :frowning: i might ask for a refund at this rate

Hi @barnett71

sorry for the delay, have you tried updating to the latest version 2.0.8?

I have downloaded latest version and still the same problem :frowning:

Hi @barnett71 have you tried setting Windows to 100% and then configure Ableton to handle the zooming ?

yes but I have a 1440p monitor so If i put windows on 100% everything else on windows is tiny and hard to see - It also doesnt fix the UI scaling issue :frowning:

Ok, thanks for testing, could you have a look at this please ?

High-DPI monitor support (Windows 10)



I’ve been having this same issue since 2.04, any progress?
Scaler1 works just fine on my system.
Whatever you guys did in Scaler1 repeat in Scaler2. Problem solved. :stuck_out_tongue_winking_eye:



Has anyone found a solution for this problem?
Just wondering if this is happening to everyone that is using a 4k screen?
I’ve updated my machine to the most recent video card drivers and windows is fully up to date, still not able to use scaler2.

ive had it 2 months now and still no solution

:confused: no solution yet ?

Hi @scalernotscaling,

No there isn’t any solution yet apart from the workaround shared higher in the thread. We understand the current situation is not ideal and playing with the scale factor or keeping Scaler to its minimal size makes it hard to use/read. We are working on improving this in the next update.

It takes a bit of time to get things right and we try to make everyone happy. We have users who would like the Scaler window to be even smaller because they use a laptop with a small resolution and can’t display it entirely…and some who would like to display it scaled-up on their 4K hiDPI multi-screen setup. It’s complicated and there are a lot of combinations to tests.

Scaler 2.1 is a few weeks away, we are all working really hard on it

Thanks for your patience and support :slight_smile: