Scaler2 crashing Reaper 64bits, win10

Reaper is very unstable in windows 10 64 bits when using Scaler version 2.1 and 2.1.1 vst2 and vst3.
The HiDPI setting to multimonitor aware v2 or unaware helps a little bit. However…
Opening a second U-he Zebra2 instance and scrolling through the presets is enough to crash Reaper.
This happens only when Scaler is loaded
At this point, I see no other option than reverting back to version 2.09. Hoping for solution

(2 non HiDPI monitors, i7 8700k, 32 Gb mem,

Have you experimented with the dedicated/separate process or buggy mode settings?

Yes, I tried all these things. Still crashing Reaper

So I installed Scaler 2.09 again. No crashes after several hours of use. Driving multiple instruments with it like Zebra 2. No problems found, changing presets and even hotswapping of plugins that were linked to Scalers output did not crash Reaper. I hope you guys find the cause of this changed behaviour of version 2.1 and onwards. I would appreciate the use of the newer functions, so can i provide a wer crashfile or something?

On another thread audio detection was found to cause some strange behavior, have you tried switching that off with 2.1x versions?

Thanks Avifi, good thinking! It seems that audio detection was also here the culprit .

Installed 2.1.1 again, switched off audio detection and Reaper seems stabile. Running multiple instances of Zebra2 with Scaler for at least a hour now at also a much lower CPU rate and the controls/sliders etc are not stuttering anymore. I wonder why my system is so sensitive to this bug?

1 Like

Microsoft usually suggests to create a new user account and run SFC scan no matter what the trouble is :wink:

Apart from that you could try to run the audio troubleshooter (see point 2 on the following link). As for the rest of the points, I’d try reinstalling drivers before applying any Win updates - and I would avoid general drivers when ever possible…

That said, if I had to bet I’d put my euros on point 12, but this is just a (not educated but self learned) guess, haven’t tested it.

Here’s a pretty thorough guide if you think point 12 might be your issue:

And as always, make sure your backups are in order before playing with drivers or installing Win updates…


Appreciate the tips, however I am not sure if this applies here because I have no windows audio drivers running, onboard sound is on purpose disabled (checked). I only use a Focusrite Clarett 4 PreUSB system with dedicated pro-audio drivers. So all audio in/out goes through this interface. I can imagine that there are so many PC audio configurations possiblewhich all work and this time my PC was among the fragile ones. Still no Reaper crash, hurrah!

There’s always the OS counterpart (stack of drivers starting from USB etc) for whatever external device and drivers you’re using, the MS steps aim to fix that side of the equation (audio troubleshooter probably checks the vendors drivers compatibility with whatever Win updates you may have also, dunno for sure). When Reaper crashed I recall the error message had a reference to ntdll.dll, this might be an indication of corrupted system files (caused by the crash or what ever happened just before it).

Then again system driver issues would usually cause more trouble than with just one plugin so it’s a bit far fetched, I know. Running SFC (system file checker) from time to time is a good practice to prevent many issues anyway, might save you from bigger trouble in the future.

I even tried disabling Cortana which I never use (it’s default is to sit in the background doing… audio detection…) but that had no effect on the issue.

The good news if you didn’t notice they’re releasing bugfix (several actually) to Scaler 2 TODAY! This is the coolest plugin ever, better than magic mushrooms :wink:

Hi @Jurgen

we have just released an update which improves the stability on Windows:

Let us know if it fixes your issue.


Found it.Focusrite Clarett 4 USB switched off, no crash, when switched on, reproducable crashes.
It had to the interface, there was driver update recently and a new one after that:

“Updated USB Driver to version 4.65.5. Changes since last main release (4.63.24):-Fixed an issue that caused some DAWs (namely Studio One, Reason and Sibelius) to expose unsupported buffer size options”

After drive update , no more crashes. Perhaps combination Scaler as first inserted plugin in Reaper is vulnerable combination. I run the DAW at 96.000 Sample Rate and buffer size of 256. Hope this info helps

1 Like

Thanks for letting us know, this will surely help other

Hi Ed, more info
I think the Focusrite driver is causing this. When I updated the driver to 4.65.5, the device settings went to 48.000 Hz and 256 (did’t notice that at first). The crashing started again when switching back 96.000.
Scaler is stable at 44.100 or 48.000, not at 96.000. I attached the wer crash file. I reached out to Focusrite with same info. Best, JurgenReport.wer