Scaler2 for iPad midi output to Korg piano

I need to engage the Midi output running Scaler2 on a iPad Pro with a lightning cable to midi in/out adapter. I have midi in but can get Midi out to the keyboard to play it via the korgs analog outputs. Is this do-able?

Yes just go to setting / bluetooth Midi settings or hit the detect record button and choose your midi output from there.

Thanks Davide for responding. That didn’t work. I’m using Scaler2 iOS on an iPAD Pro connected via USB to a Korg Grandstage 88 using the USB-A port. I have midi from the korg to scaler but I can’t get Scaler to transmit midi out to the korg.
I noticed in your video introducing the iOS version the iPad you where using appeared to be wireless. Was that correct? I’m using a hardwire connection.

1 Like

Scaler will be transmitting MIDI automatically, so maybe it’s a setting in the Korg. Make sure it is set to receive MIDI. Looking at the manual here ( ) it appears the Grandstage 88 only accept MIDI via MIDI connection unless you install the USB Midi Driver from Korg, so I guess if you want to use USB for MIDI you need to do that!

Thank you so much for researching this!
I’ll give it a try today



Hi, Still not working. How can I verify the iPad Pro is outputting a midi file from Scaler on iOS? The Korg driver idea is only applicable to a windows device. I’m still stuck. I have a IK multimedia IF for Midi but that is not outputting midi from th ipad.

Not much we can do to help you here @glennpeacocks I’m afraid, as mentioned, Scaler is always sending MIDI so it has something to do with your setup which as you can understand I can’t diagnose from here. If you get a chance connect Scaler iPad to something else and you will see it receive midi.