Scaler2 freezes in Reason 12

Scaler2 worked just perfect in Reason 11. Now in Reason 12 it freezes at the first touch of any button within Scaler2. Probably a Reason 12 issue, but I wanted to report it here as well.

Win10, Intel i5


Hi @Joe_Nice works fine for me in Reason 12 on a Mac, shouldn’t be crashing. I’ll wait to see if the DEVs can provide anything further. Any other Reason 12 / Scaler PC users?

1 Like

I am having the same issue as well just upgraded from Reason 11 Suite where everything was working fine now having all types of issues in Reason 12. Scaler2 Crashes Reason 12 first it freezes then program shuts down. Also some of my vst plugins like serato sample and serum now are super small and i cant scale them to be bigger in size.

PC? Details? Thanks @huntspoint20

My Laptop Specs are
Dell XPS 9560
Win 10 Pro
4K UHD Touch Screen Display
1 TB SSD, 32 GB Ram
Intel i7 Quad Core 2nd Gen
Nivida GTX 1050 Video Card

I’m having the same problem @Joe_Nice. Perfect in Reason 11 on my iMac . The weird thing is Scaler 1 still loads and works fine?

I have deleted the plugins and reloaded everything again. Still the same.

This was resolved with the latest update in Reason.