Scaler2 iOS causing 99+% CPU usage with Atom2

Been using desktop Scaler2 for a bit, now trying out the iOS version on an iPad 8th gen (all iOS and apps mentioned are up to date)

I’ve set up a very basic session in AUM, with Scaler2 on an audio track, a basic piano on another audio track, and Atom2 Piano Roll on a MIDI track.

In scaler2 I have a single 4-chord progression set up, with no performance turned on. It’s left on the Pad screen. I use AUM to MIDI route Scaler to control the piano.

In Atom I have a single looped pattern set up that just plays the control notes (C3, D3 etc) that play the 4 chords in the Scaler chord sequence, and the Atom MIDI routes to Scaler.

I’m kind of assuming that this should make sense (similar logic to how I use Ableton midi tracks to control scaler in there). It works for a few loops But very quickly the DSP / CPU usage AUM reports hits 99%, 100%, MAX - and Scaler stops sending out MIDI to the piano. If I have saved the session and I reload it in AUM, it’s at MAX DSP and not working from the start and nothing fixes it except completely removing the Atom instance. But - AUM reports that it’s definitely Scaler2 that is using the 99%+ CPU.

Sorry if this is covered by something simple / RTFM, but I’ve been searching for an answer for a while, am I fundamentally wrong in using Atom to try control Scaler like this in AUM? Have I set up some kind of circular MIDI processing without realising? Any other ideas?

Note: similar thing happens if I set this up in Audiobus too; it happens with all the other variants of Scaler available in AUM (ScalerControl etc); it COULD be iPad gen8 is slow for present day, but it seems to do alright with a bunch of simultaneous samplers / Borderlands Granular etc in AUM…

Hi @Jimp

You can disable the live audio detection in Scaler. This should save some CPU cycles.

Click on the « audio » button at the top left of the screen next to the Scaler logo.

Let us know if it improves,

Unfortunately not - I think I had that off to begin with but I double checked in an entirely new AUM session - this time as simple as I can make it just Scaler2 on one track using the internal Felt piano audio output, and Atom to drive the Pad chords/chord-sets. Audio detection definitely turned off!

This time I can isolate the behaviour: Atom correctly triggers the chords and chord-set changes the first time I hit play on Aum‘s transport; scaler plays sound correctly, CPU at 25% or so. If I hit pause on the transport, CPU hits max and there’s a buzzing sound from speakers /headphones. Nothing can fix that except a close of AUM etc.

Hi @Jimp

If the overload happens when the playback stops it might be related to another issue that was reported on Ableton. Do you see the same overload when you click on the “MIDI Panic” button?

We have recently worked on this and the next update should improve CPU usage.

MIDI Panic doesn’t help (in iOS, that’s tapping on the MIDI word top left, right? It produces a little pop-up saying MIDI Panic anyway) - CPU usage is unaffected, still at 98%-MAX; AUM still reports that is all taken by Scaler even when nothing is happening (no AUM transport etc)

Are there any more thoughts on this issue? Has anyone else replicated it? Once I’ve checked all my backups I might resort to uninstalling and re-installing AUM, Aton and scaler 2 to see if that helps

Had this same issue with Atom2. I now use Drambo inside AUM to drive midi to scaler2. Drambo doesn’t cause the cpu to spike up to 100%.

Hi, I had this same problem. Did you watch the tutorial on YouTube with the guy with 3 Atom2s on one MIDI lane and 3 Scalers on another? He doesn’t know what he’s doing, just for reference of anyone who Googles this. When you have them on separate channels like that it triggers this behavior. You need to have them on the SAME MIDI lane, and route them like this:

Scaler 2 output->Atom2 input | Atom2 output->AUv3 instrument input

You can have multiple Atom2s on the same channel as Scaler 2 and re-route Scaler to different ones. This is the way I do it for chords, melody, bass line etc by using the Performance Mode.

1 Like

Hi Nickca,

I have the very same issue; on pausing transport, scaler 2 will crash when receiving midi from Atom 2. CPU spikes up to 117%.
Having Atom control another audio device does not show the spikes; having another midi source controlling Scaler works fine too. It really comes down to the combination of Scaler and Atom 2.

However, I use Loopy Pro, and it doesn’t stack devices together in lanes as in AUM.
Could you please elaborate on your solution, hinting on the underlying stuff happening and why it causes the CPU spikes?

Thanks in advance,