Scroll wheel fails on horizontal scroll through chord variations list

2.0.5 VST 3 | Windows 10 | Bitwig Studio

If you use the VARIATIONS button to view all the variant chord list, you’re currently forced to click and drag the scroll bar beneath the list, because attempting to use the mouse or trackball scroll wheel to scroll the list will “freeze” up only part way through the list.

1 Like

Hi @Baphometrix,

have you tried scrolling (not clicking) with your mouse pointer hovering the bar ?


Yes, I have tried carefully putting my mouse pointer over the scroll bar beneath the Variations list. The mouse wheel scroll does not work there either. Not even in the latest 2.08. In Windows 10, on two different types of mice (regular and kensington trackpad). The ONLY way to scroll the list for me is to click and drag the Scroll bar.

VST3 | Windows 10 | Bitwig 3.2.1

Thanks you for the details. That should be working, this is strange, we still haven’t been able to replicate this issue on our side, but I think we will need more details from you as you are the only one having this issue.

What kind of computer you have ?
Do you have a touch screen (Bitwig has touch capabilities that could possibly interfere with scroll here depending on configuration) or some system or device specific ergonomic preferences that could impact the pointer you use ?
Are your two mice connected at the same time ?
Have you tested one after the other ?
Can you think of any other USB devices that could interfere with scrolling, a MIDI mapped controller or XY pads that could be configured to scroll or any kind of device that could be blocking/affecting the standard scroll behaviour ?

Does it happens with the VST3 or also with VST2 ?
Have you tried with Scaler2 and ScalerAudio2 ?
Was it working in Scaler 1.8 ?
Do you have a possibility to test in another DAW ?


Windows 10 Home | Bitwig Studio 3.2.1 | i9 9900K | 64 GB RAM | Motu M4 | Geforce RTX 2070

Scaler 2.0.8 VST3 and VST2 (same problem on both)

No touch screen. Just two 1080p 27-in displays.

The same problem occurs whether both mice are connected at same time AND when only one is connected. It does not matter. The problem is identical on both.

NO OTHER APP I HAVE is adversely affected in its scrolling behavior like this. No DAW. No VST. Only Scaler 2. FWIW I still have Scaler 1, and the horizontal scroll in the VARIATIONS list works PERFECTLY.

This is 100%, positively, a regression introduced in Scaler 2.

No other USB devices like you describe in your question.

Happens with both VST2 and VST3 of Scaler 2.
Again, Scaler1 works PERFECTLY in this regard. The problem is ONLY with Scaler2

I have also tested this issue in Ableton Live 10.1 and the problem is IDENTICAL there too.

Yes the IDENTICAL problem also exists in ScalerAudio 2 (both VST3 and VST2)

Thank you very much for the feedback, unfortunately we still haven’t been able to replicate yet.

I can show you a video or hop on a Zoom/etc. session with you and show you in real-time. It’s absolutely 100% reproduceable for me and it’s 100% a regression from Scaler 1 (which I still have and which still works perfectly fine in this regard). You did something new with a mouse action library in Scaler 2, for sure.

May I suggest that you test with a Kensington Trackball Pro and the associated “Trackball Works” driver app that is installed with a Trackball Pro? My only hunch (since you can’t reproduce yet) is that the regression is tied to something to do with the driver app for a Kensington trackball mouse.

BTW there is literally no other app of any sort on my system that is having an issue like this. Not business apps. Not games. Not any other VST or DAW. And not Scaler 1. Literally, it’s only Scaler 2 that exhibits a regression like this.

Don’t worry, we got your feedback and are considering them in our ongoing investigations. We will keep you posted on advances made. Until then, sorry for the inconvenience.