Setup Cakewalk / Sonar / CbB: How do I make Scaler trigger other vst from Scaler's paino keys?

Lol I should say also sorry Ed1 if I came off as a jerk man and you have certainly tried to be very helpful and your Scaler program is badass and getting better, but just channel 1? Lol k I’ll drop it.

Hi @Bo_Baker, @slydyne,

It seems there’s some confusion here about the MIDI routing and what you can do with Scaler.

Scaler receives MIDI from your DAW and can transform it. The transformed MIDI signal is output by Scaler on its channel 1 (by design).

Unless you routed the MIDI in a specific fashion, Scaler doesn’t broadcast its MIDI output anywhere.
Internally Scaler could output 16 different MIDI signal (1 per channel), when routing the MIDI you have to tell you external instrument to listen to a specific track and channel.

If Scaler outputs to all of your instrument it is because either:

  • All of your instruments are configured to listen to Scaler’s MIDI output
  • You routed Scaler’s output in a way that it is redirected to all of your tracks’ MIDI channel 1

To make sure of this:

  • Add a track into an empty project in your DAW and load Scaler.
  • If you add another track with an instrument, playing on Scaler doesn’t trigger any note on the new instrument.
  • Now if you tell your second track to listen to Scaler’s MIDI output, the signal is routed to your instrument. Scaler can now “control” the new instrument.
  • If you now add a third instrument, playing on Scaler still doesn’t trigger notes on it, unless you make it listen to one of the tracks Scaler’s output is redirected onto.

I understand how it can be slightly different depending on your DAW and its routing capabilities. For example, some DAW allow you to redirect Scaler’s output onto a MIDI track that you use as the source for your routing. In that case it might complicate things a bit if multiple instrument were already configure to listen to this common MIDI track.

Midi routing can go from really straightforward to awfully complicated, so I hope I haven’t added more confusion as it also depends on your setup and the configuration of your project.

Also @Bo_Baker, make sure you use the VST2 version of Scaler as the VST3 still has some issues with routing.

Let me know if you need further help on this.

Cheers,
Ed

Hello Ed1 and thanks for jumping in. I do understand the “routing paradiam” for Scaler. My only issue was getting it to route in SONAR (I was/am using the VST3 dll so I will try the VST2 today. However; It took me about 90 seconds to get the VST3 dll to work in Reaper (my second DAW). In Reaper it is strait forward and makes perfect sense. So, there you go. SONAR’s routing has always had issues and while a fantastic product, this is its weak spot as far as a learning curve. I’m not saying it can’t be done - and I will figure it out in time. It most likely will take more than two tracks (i.e. Aux tracks) to get it to work. If I do figure it out, I would be happy to pass my findings along to both of you as a “Thank You” for your help.

So to recap: Reaper is working fine and is a simple process. SONAR has issues (at least with VST3 dll) and I’ll see what I can find out and report back.

Thanks again for all the help. Scaler is a great program and while as a Jazz guitar player I’m pretty well versed in theory, this is a real time saver and inspiration tool. Keep up the great work (I have done programming and I know what it takes to get something like this to market!)

Blessings, Bo

Bo, I also listed for you how to route Scaler in Cakewalk /sonar to get it to work on channel 1 like I have. Are you saying you tried that and it’s still not working for you?

Hello again Ed1, are you saying that YOU have it working in SONAR or that your directions SHOULD work. Yes, I tried your directions and no joy. How familiar are you with SonarX3 in my case? There are two ways to create and Instrument track. One is called a “Simple Instrument Track” which combines one Track into both an Audio and MIDI Track. Some things are hidden but you should be able to make this work by following your instructions. The other way is to create two independent tracks, One an Audio Instrument track which holds the Instrument VSTi and the other a simple MIDI tract that defaults to being routed to the VSTi track.

I have tried both implementations and still no joy. Since I have Reaper working as you have outlined, I am about to give up on SONAR (not giving up on your product!) and move on to making music. Perhaps another night’s contemplation will reveal the “Magic Souse” that will open up the door.

I really appreciate you time and efforts on this but at this time feel your time is better spent programming. So unless it is important to you to try and "wring this issue with SONAR out, We can call it a lost cause and just move on. That’s fine with me.

Blessings, Bo

Perhaps I should say that the only part not working is when you turn OFF the “Scaler Speaker Button” and depress the Virutal Scaler Keyboard or depress the “Chord Buttons” or play the Scalar Chord Progression Player. I am seeing MIDI being transmitted out Scalar but nothing but it is not recognized by the VSTi Audio or VSDi MIDI track. I tried using both OMNI MIDI and both ends and Channel 1 at both ends. No joy.

Bo is speaking only for himself here in regard to writing this off. While it may be ok for him to call this a lost casue thus leaving it unresolved and moving on (and who could blame him), it is not ok with me. I use Cakewalk exclusively, and for me the answer is not to simply use some other daw for Scaler’s sake, no f’n way. I bought this program and started this thread and I consider the matter still unresolved.

And I have to say, notwithstanding the initial learning curve of a daw I’ve never really had any routing problems in Cakewalk (which I’ve used exclusively since pro 8) w/ any vst until Scaler. Perhaps Scaler is working great in whatever other daw someone’s using and that’s nice, and while I certainly appreciate what Ed1 is saying up there, the fact remains that, in Cakewalk, Scaler can only work on midi channel 1, plain and simple, no dancing around that w/ whatever explanation - and I find it incredibly limiting and annoying and wtf. One can chalk it up to how Cakewalk handles routing; I chalk it up to Cakewalk handling routing just fine for me since pro 8 until Scaler.

Ed1, I’ll repeat the specific Cakewalk-pertaining question I asked you in my last post which was not addressed:

Since Scaler will only work on midi channel 1 in Cakewalk (and I’m not switching/buying some other daw that Scaler likes better), if I have a session going w/ a bunch of vsts, and one of which is already assigned/routed to channel 1, and later on I decide to bring in Scaler to help w/ songwriting… BUT as Scaler only works on channel 1 I’m forced to have to re-route that initial vst that was assigned to channel 1 and find it some other midi channel as well as re-routing its corresponding midi track just so Scaler can work on channel 1… I mean it’s either all that or always reserve channel 1 for Scaler … Seriously, don’t you get what a total PITA that is? With pretty much any other vst you can simply route it to whatever midi channel you need it on, plain and simple and no headache. But here’s Scaler, and it’s either channel 1 or no functionality in Cakewalk. You can explain it away but that’s just how it is - and if I’m wrong on that I’m still humbly/hopefully waiting to be corrected as it pertains to Cakewalk.

And speaking of Cakewalk, Ed1, previously you mentioned that you were going to download Cakewalk by Bandlab (currently free) and look into how Scaler is functioning in it. Perhaps you should finally give that a try so you can see for yourself what I’ve been talking about all along, so that either you can set me (and anyone else using Cakewalk) straight, or not. Because with all due respect your greatly appreciated explanations are not changing the fact of how Scaler is behaving in Cakewalk.

BTW, when you say to “tell your second track to listen to Scaler’s MIDI output” - the only way to do that in Cakewalk is to assign a specific midi channel, which in Cakewalk/Scaler’s case is that midi channel 1 only deal. In Cakewalk, you can’t just tell one thing to listen to/trigger another without getting midi channels involved. If I’m wrong on that, correct me. Thanks.

Hello Slydyne: I did not mean to hi jack your postings, so apologies if that is how you see it. My intent was to simply bow out at this point as I have a solution for me. I too have used Cakewalk since Sonar 5 and have had no “long term” issues with Sonar’s routing. But as a Top notch DAW it provides many ways to route things and it seems that Scalar is looking for a specific paradigm. I’m OK with that but just can’t get the right things to connect. The fact that Scaler works in Reaper and several other DAWS tells me that MY issue is in understanding what the correct procedure is to connect Scaler’s in/outs to Sonar’s in/outs.

Are you saying that you DO HAVE SCALAR WORKING in SONAR?! And your ONLY issue is the forced Channel 1 issue? If you do, Please tell me your connections - I’d love to get this working. Perhaps at that point I can help you with a work-a-round for your issue. I’m not totally giving up but wanted to give ED1 a breather while I continue to read, try, think, search for others with the same issue. If you have anything to share I thank you.

PS I should include that I am using SonarX3 as I had no intention of going to the “Subscription on a Cloud” route that Cakewalk tried as a “last gasp” attempt to stay solvent. I’ve looked at the BandLab Sonar and it appears to be no different than SonarX3 - just with fewer “free” plug-in that I have gathered over the years.
Are you using BandLab Sonar or one of the “X” series?

Blessings, Bo

Hi Bo, yeah man that’s what I’ve been saying the whole time here, that I have Scaler working in Cakewalk BUT that it works on midi channel 1 only, and I’ve been trying to figure out how this “channel 1 only” design is actually a good, efficient and useful design when for me it’s absolutely anything but.

Bo, in one of my last posts I already laid out for you exactly how to route things in Cakewalk the way I have them routed where Scaler works on channel 1, so please see those posts for those instructions, scroll up and you’ll see it.

I was using X3e before I “switched” to Cakewalk by Bandlab (CbB). The routing is exactly the same in both as is just about everything else. As far as CbB not having as many plugs come with it; the plugs that came w/ Sonar X3e will be available to you in CbB. Even more so if you have Platinum. The difference is that Sonar X3e/Platinum will never be updated again unlike CbB.

Bo, if you end up able to help me with a workaround for my issue… that is, if you are somehow able to get Scaler to work on other midi channels rather than just this lowly channel 1, I believe you will have solved what I consider to be a design problem, not a “I don’t know how to route things” user error problem. In other words, I don’t think anything is “broken” or not being done correctly here, I think this is, according to Ed1, the way they designed Scaler and/or how it functions in Cakewalk, and I’m sorry but my experience is that it’s an unnecessarily limiting and poor design. Look I’m just telling it like I’m seeing and experiencing it, and with all due respect to the designer, maybe the design needs a little rethinking as far as the midi implementation, or lack there of, goes… *Or point out to me where I’m wrong and explain to me why this “channel 1 only” functionality is actually good, efficient and ideal… * I’d love to hear that explanation and I’m not not being snarky.

Hi @slydyne,

I have just tested in Cakewalk and I can’t really understand what is the issue here. The routing works well on channel 1 and I can route Scaler’s output to specific tracks.

Here’s the setup I used:

Everything I used to configure is visible on the screenshot, there is:

  • One track with Scaler (VST2) configured to receive MIDI from my keyboard
  • One track with Massive configured to receive MIDI from Scaler’s channel 1
  • Make sure you turn on the monitoring of the destination track to hear its output

I hope this helps, let me know if I have misunderstood your problem.

Cheers,
Ed

ED1 Tried to replicate your image set up. still no joy. When I turn off the Scaler Speaker button I get no sound. Was your’s done in SONAR or some other DAW? I looks like you did a "Simple Instrument Track if that is SONAR. That meas that the AUDIO and MIDI are on the same track and some of the MIDI options are hidden. IN Sonar you have the option of making an Instrument (VSTi) track and a separate MIDI track to trigger the Instrument Track. I’ve tried both but no joy when it comes to getting Scaler to trigger the VSTi from Scaler with the Speaker button off.

Just don’t understand how you and Slydyne have Scaler making sound from the VSTi when playing Scaler’s keys or pads with the Scaler Speaker. I will take a screen capture tonight and upload it for you to look at. Thanks a $$$$$$.

@Bo_Baker

Are you using the VST2 ?

I have tried both but I am going to try the VST2 in a few minutes. Here is a screen shot of my latest try using your settings as best I could.Scaler1

This looks like what I have done with the VST2, so I guess it should work.

I am not a Cakewalk user but when I added the track I did: Insert > Soft Synth > Scaler, then make sure the “Enable MIDI Output” is ticked in the popup that appears.

If the popup doesn’t appear, you can change the options here:

JOY to the WORLD - and ED1!!! With your great help it is now all working. I had to use the Scaler.dll 32 bit VST as shown above and it ALL works as it should. Tomorrow I will try the Scaler_64.dll and the Scaler_64.vst3 to see if they will work with this template.

Thanks for hanging in there with me. Hopefully, this will help others in the future in SONAR. Now I can try working on Slydyne’s issue to see if I can help him with the “channel1” issue.Scaler32bitVST

Blessings Bo

1 Like

I will try to make an outline of each of the steps (turn on this and this and this) tomorrow for future reference. SONAR has a lot of things to turn on/set to get to the end of the rainbow. But what a rainbow it is!

Blessings, Bo

PS I will let you know if I can get the 64 bit .dlls to work like the 32 bit.

1 Like

I now have both the 32 bit and the 64 bit Scaler VSTi’s working as they are designed in SONARX3.

Here are the “Detailed” Instructions for anyone having difficulties.

How to set up Scaler 32 and 64 bit VSTi in SONAR all versions X3 and forward

If you are going to load both the 32 and 64 bit Scaler Plug-ins be sure they are in different folders i.e. Folder VST2 and Folder VST3.

There are first, several items to set up in EDIT > Preferences> VST Settings

Under VST Migration: Make sure both “Hide Related VST2 Plug-ins” AND “Replace VST2 Plug-ins When Opening Projects” are NOT Checked if you are going to use both.

Next Add the VST(s) to the VST Scan Path Window

Next Press the APPLY Button and then the OK Button

Now if you are going to use some type of control surface such as a MIDI Enabled Keyboard, In the same area you are now in, go to the Control Services menu item under the MIDI menu items.

If your Keyboard is not listed in the Controler/Surface column you will need to add it here in order for it to be able to connect to your VSTi(s). You do this by pressing the Yellow Wave icon next to the Red X icon.

This will bring up a window and ask you to choose a Controler and configure its Input and Output ports. If you don’t see your controler, we suggest you choose “Cakewalk Generic Surface” and the In and Out ports of your DAW interface hardware. Again depress Apply and then OK.

YOU ARE NOW READY TO CREATE A NEW PROJECT,

Give it a name and add two Audio Instrument tracks. You do this by choosing from the Main Menu INSERT>Softsynth>…(the location where you placed Scaler).

This will open a Window with several Options on how you want to load this Instrument VSTi. Here is the easiest way.

Simply check the “simple instrument track” box and the “Enable MIDI Output” box. I’d leave the “Ask this Every Time” box checked as this is its default.

This will place Scaler on your first track and expose the next set of items we need to set
In the Track View expand downward until all the options for this track are in view.

Set the Input drop down to your control (keyboard) and choose channel 1. IT IS VERY IMPORTANT THAT YOU CHOOSE CHANNEL 1 (or OMNI if you are only going to use the two tracks in your project).

Next set the Output box to your MASTER .

Make SURE that the MIDI ECHO button is on in the track and that the tracks Ready to Record is depressed. (Depending on your set up options this may be done automatically)

That completes the Scaler settings for now.

Next add a second track for your Instrument VSTi by again choosing from the Main Menu INSERT>Softsynth>…(the location where you placed your Instrument VSTi).

This will open a Window with several Options on how you want to load this Instrument VSTi. Here is the easiest way.

Simply check the “simple instrument track” box and the “Enable MIDI Output” box. I’d leave the “Ask this Every Time” box checked as this is its default.

Set the Input drop down to Scaler - and choose channel 1. IT IS VERY IMPORTANT THAT YOU CHOOSE CHANNEL 1 (or OMNI if you are only going to use the two tracks in your project).

Next set the Output box to your MASTER .

That completes the VSTi settings for now.

Make SURE that the MIDI ECHO button is on in the track and that the tracks Ready to Record is depressed. (Depending on your set up options this may be done automatically)

AT THIS POINT YOU SHOULD BE ABLE TO PLAY YOUR KEYBOARD AND HERE SCALER PLAY A TONE.

Next open Scaler VSTi properties window and with your mouse play the virtual Scaler keyboard. You should again hear Scaler play a tone.

Next depress the SPEAKER located in the upper right hand side of this window just to the right of the Registered button. By depressing the Speaker button you will disconnect the Scaler’s tones and re-route the MIDI signals to your VSTI track…

So now you should hear the tones coming from your VSTi instrument by playing your keyboard controler and/or Scaler’s keyboard, Chords or Progression Player.

We HIGHLY recommend that you make a Project Template in SONAR and use that as your starting point for any future projects. Just remember to Save your template with a different name before you start your next project to prevent your overwriting the template itself.

Hope this will be of help to others. Blessings, Bo

1 Like

Ed1, dude… Respectfully, you couldn’t be less helpful here.

Ed1, I posted a detailed question to you back there regarding my work flow and bringing Scaler into a session later on in a session and how this “midi channel 1 only” functionality is a problem… AND again you’ve avoided answering my question. I don’t know if you’re being deliberately obtuse here, just not reading what my posts are actually saying to you, or what your deal is man but suffice to say that I am incredibly frustrated, NOT happy w/ your Scaler app or the $50 I paid you for it and if Scaler were a piece of hardware I’d have returned it due to this limited midi channel 1 only functionality. The closest you’ve come to answering my question was you basically saying, ‘Well we designed Scaler this way because that’s how we designed it’… which does nothing to help me or answer my question.

Matter of fact I’m requesting a refund. I know it can’t happen because it’s software but I want you to know how unhappy I am.

Hi @slydyne

sorry I couldn’t be more helpful here. I have been trying to explain how and why it is not an issue because the only channel1 Scaler is using is its OWN channel1 not some sort of global channel1 in your DAW, UNLESS you have routed it this way.

I understand the frustration, but I really can’t wrap my head around your issue or how Scaler can be at fault here. I am not saying it is not, I just think you can workaround this issue by routing differently.

Feel free to give more information with screenshots and videos showing how Scaler is routed in your project so we can at least understand why you are having this issue when nobody else has reported the problem.

Sorry to hear you will let go of Scaler for this, there are many more features outside of the MIDI routing. Let me know if I can be of any help regarding your refund, I can probably talk to the guys over at Plugin Boutique if needed.

Cheers,
Ed