SOLVED - Plugin Boutique not available as AU Instrument in Logic Pro X - Scaler 2 crashed validation

When I create new instrument track, either from new project page OR loading instrument from track menu, Plugin Boutique is not available as AU instrument. I can only find Scaler as AU Midi-controlled effect ScalerAudio2.
Logic Pro X 10.7.7 MacBook Pro M1 Pro

(sorry if this has been covered before but couldn’t find any posts in my quick search)

PS just rescanned Logic Pro plugins - Scaler 2 Crashed validation. I have reinstalled Logic Pro X AND Scaler 2.7.3 but still crashed validation.

PPS Update - deleted the ScalerAudio2.component, ScalerControl2.component, Scaler2.vst, ScalerAudio2.vst. Downloaded Scaler 2.7.3 from pluginboutique and reinstalled. Scaler 2 crashed Validation again. Checked the "use’ box. Scaler 2 now loads as instrument but does not play andremains showing as crashed validation.

PPPS Update 2: SOLVED. Following the above stage I rebooted MacBook then rescanned. Validation passed. Scaler 2 now loads as instrument and played.
Decided to leave this support query in forum in case someone else searches for this query. Thanks to the team if you’ve read this far

PPPPS love the new Scaler 2 Course. Just bought it