Unable to control Velocity -> Chords are SUPER LOUD

Hello, I am having trouble with velocity. When playing chords in PERFORM mode or just mouse clicking on a chord set, the velocity is very intense. It’s equaled to hard banging the keyboard (127). I am not finding a way to control it. Humanization only barely lessens velocity on some notes but still way hard to be usable or recordable. And in humanize mode the first chord of a Phrase being played is so loud that I have to turn my monitors down.

I remember this being the deal breaking issue with Scaler 1 for me. I had assumed after some years that this would be resolved.

Hopefully I’m missing something here. I’ve set the softest velocity sensitivity on my midi keyboard, so that’s not the issue. I’m basically feather touching the key and it sounds like a 3 year old angry child is jumping on the keyboard.

Thank you for any tips as to how to resolve this.


System, OS, and Scaler version please. DAW too.
If I play soft my velocity response is soft. Clicking with a mouse will always be 127. Kontakt behaves the same. My OS is 10.13.6 on an iMac. Scaler 2.5. Same in Ableton Live or Cubase.

Thanks for the reply J.

Win 10, S 2.5 (just purchased), Ableton 10. Yeah it seems clicking and actually hitting the PLAY button in Section A pegs at 127…pretty annoying to have to reduce volume by -10db each time I click a note, and then readjust it back up with actually playing the keyboard myself. Dev wise this should be an easy code fix. Not sure why this is still an issue after so long.

You can adjust velocity under edit chord but you need to move the chords from Section A.
As an aside… I only use headphones and I never have a problem of the volume being too loud even if I click on the pad with a mouse. Ever. How loud are you listening?
[ADDEMDUM] Going back to confirm this and Scaler responses to velocity only when expressions are turned off. When expressions are turn on then it seems to be using the velocity of the performance. So, yes it would be nice if velocity response could happen when you play soft. Humanize helps some and I know that in an update that will get better.

Welcome to the forum @KDUB - yes but unfortunately mouse clicks or trackpad clicks are not velocity sensitive, we have toyed with the idea of an overall internal volume control but there’s very little feedback to suggest it should be prioritised. Will come though…

Thanks guys for the replies. Just to clarify, this is happening when the PERFORM button is pushed regardless of if I port the midi to another instrument or not AND when playing an instrument patch from Scaler. During perform, all velocity seems fixed at the default for all keys (89 i presume). David would it be that much code to write to have a global velocity setting which would apply to mouse clicks? I can’t imagine I’m the only one out there clicking a chord with my mouse to preview it. At normal volume for my other sounds, when clicking a Scaler chord I clip both my interface and the master channel in Ableton. It’s a good 10db higher than any other sound. It’s a literal shock.

Are you able to repro this behavior? Thanks for looking into it.

Also I’m finding that when binding chords in section A and playing the Scaler instruments with my midi keyboard (in Ableton)…the velocity is pretty much black or white. Very loud. The softest i can play registers at the 89 default which is way loud to achieve any type of feel while playing the Scaler based instruments.

I’m surprised more people aren’t reporting this.

It is also possible that those of us use Scaler for what it is: to generate chord progressions and ideas to compose.
Surely the improvement you suggest would be good for everyone, but I prefer that Scaler continues to develop on the path that it takes.
As for the instruments that Scaler incorporates, I will tell you that normally I do not use them. I always send the Scaler output to another track in Ableton with another Vsti, Scaler silence, and when I punch over a pad (a chord) I hear the sound of that Vsti. I also adapt the velocity and volume curves on that track. Try it. It works for me.


I work rather like @jjfagot; I audition scaler content looking for ideas with it sitting in Cantabile, and make a list of things to subsequently pull out and develop.

I then fire up Live, and then drag the midi over, so the midi velocity in Scaler isn’t really an issue - I can edit in Live. The feeble stuff I do largely tends to centre on sounds (from JD800, Omnisphere, DUNE, Absynth {now … tku @Bernd} ), so in Scaler I just use either piano or strings.

The bottom line here is that everyone will have their own way of working, and I can see that if you are using a keyboard directly to Scaler you are going to lose the nuances of expression. In the rare cases I do (attempt) to use a keyboard (other than as a controller) I tend to use the JD800 as it has after-touch with which you can invoke its resonant filters.

1 Like

Yes I also don’t use the Scaler instrument…i was merely reporting that the issue happens when using them FWIW.

York…i port Scaler to other instruments (kontakt, omni, etc.). Velocity issue happen when previewing chords with mouse-clicks, when previewing chords with Scaler instruments, and when using the Performance feature (which is cool and handy), yet not usable due to this issue. It would be nice if Velocity issues were fixed. They obviously didn’t design this issue in. It’s a bug or an overlooked issue. And a very easy one to fix.

I understand that if you’re not using a feature that it’s not an issue for you. But like you guys point out, everyone has a different workflow, and we all paid for this program to work in logically expected ways. Adding an immediate +10db blast to your sound field isn’t something that any DAW or music software should do.

1 Like

There is nothing to report. Scaler is never too loud on my system. I use headphones because I’m in a small place and I have never once had Scaler louder then any other instrument on my system. You must have your audio really cranked up.

Might be because most people use Scaler’s MIDI output to drive other instruments. I for my part always have intermediate plugins that alter the character of the MIDI, such as velocity, gate length etc. Many DAWS these days have MIDI alteration features.

E.g. in Bitwig, you can remap the velocity onto a custom curve…

But I hear your point, it takes away the quick improvisation within Scaler without much plugin-chain/DAW overhead. Surely something that is fairly easy to fix in future Scaler versions.

1 Like

That’s it.
In Ableton you can use Midi effects - Velocity
There are several presets, but you can customize your own

Scaler sits well below a vast majority of synths that I have run terms of dBFS - do you use Omnisphere / Serum / Massive X or pretty much any other modern synth? Ouch! I totally get what you are saying and agree there needs to be more control, which is happening along with a host of other internal sound adjustable parameters. Will happen 2022.

Hi David, yes Omni. Falcon, Hive, Kontakt, etc. thru Ableton and Cubase.

This thread is more about “clicking” on a chord, less about how I use my instruments…Just measure the relative difference in Db when 1) playing inside of scaler (via your midi keyboard) and 2) then clicking the Chord with your mouse and/or using the PERFORM function (thru your midi or otherwise). That’s it. Do that and I think the issue will be made clear. This (2) is when the velocity relies on the default as set inside Scaler and this is when the “boost” (to put it nicely) is happening.

I think I’m doing it normally hahaha…or so I hope after all these track releases over the years :slight_smile:

BTW, I don’t use the internal sounds in Scaler but you guys did a great job of adding some nicer example sounds in this version. Thanks for all the good work and I’m seriously wondering what you have in store for v3. There’s so much there already…so I can only imagine what you guys must be cooking up. I’d hope for some type of AI/algo type PERFORM functions. Could be fun to see how the robots will takeover haha.

When you click it plays velocity 127 which is the same as the loudest keypress on your keyboard. There’s no jump from 127. Also we’ve tried to average max at -6.3 dBFS, we never go near full scale as many other software does, in fact most synths I own have many patches that don’t respond to velocity so patches regularly hit at 0dB! Hence I don’t understand the super loud comment. Am I missing something? I do get that an overall volume control makes sense and that the disparity between soft keypress (0-15) and 127 can be large but most people hit keys at 80+

David you nailed it. Like you said when you mouse click it registers as a 127 velocity!! That’s a huge difference from a normal playing velocity of 40-90. So don’t you see that as an issue?

Think about it. Your system is sitting at the proper monitoring volume for how you play (vel 40-90)…so you’re riding along…all is at normal volume…and THEN…you mouse click a chord pad OR use the PERFORM function…and BOOM a 127 velocity routes to your instrument and thereby to your master gain (which was playing at unity with your normal playing velocity), now pegs a +10db. Your interface goes into the red, your ears get rocked, and the feel of what you were working on gets abruptly interrupted.

I’d be happy to record a video if you’d like.

This makes no sense. That would mean that anytime you played 127 velocity on any instrument it would blast your system. Sorry there is something not right with what you are saying.


Fully appreciating your concern, I was thinking about a tactical workaround, until the product offers the feature you’re looking for…

I struggle with a similar issue with various soft synths - not because of the software, but the presets that embedd the default volume setting. Some preset banks have the volume setting all over the place, so when I jump from preset to preset at the same speaker volume setting, it’s either too quiet or too loud.

So I got into the habit of putting a Peak Limiter on my Master track. I’ve seen others do the same, so that seems a fairly common practice. I suppose a Compressor might achieve a similar effect. Was just thinking this might be useful for your situation also, perhaps?