Unable to control Velocity -> Chords are SUPER LOUD

Jamieh, not everything…like I’ve pointed out a few times…ONLY when mouseclicking in Scaler and/or using the PERFORM function in scaler. Also DIRECT mouseclicking on the top section keyboard in Scaler. I just discovered that. I think I’ll upload a video so you guys can clearly understand what’s happening.

Bernd, yes a peak limiter on the master is a good idea. But my intention here isn’t to find a workaround, it’s to notify the team that there’s a design flaw (not technically a bug). And I’m hoping they can address it in the next patch release.

I’m unable to upload videos here, but I just took two videos so that you can see the issue (link below). Normal velocity midi keyboard is around -6Db, and clicking a key or chord with the mouse in scaler pushes up to +9Db!! That’s a 15 Db immediate increase.

On my system, in Ableton Live 11 or 10 - Scaler on a track and mouse clicking on a pad my VU is -10 at best depending on the Scaler sound. If I add Utility and boost the output of Scaler by 12db I still don’t go into the red like your video. I go to 0db. If I boost the output to the Max of 35db the sound flattens at the top of the VU but does not give me that red that you get.
Mac OS 10.13.6 / Ableton Live 10 and 11 / Focusrite 18/8 / Scaler 2.5
Is that Scaler on your track without anything on the output?

Correct. Nothing on the instruments. I’m soloing 1 instrument in kontakt and in kontakt it’s volume is a 0. I also tried it with Omnisphere where I’m getting a 12Db difference there when clicking a chord versus playing a note on my keyboard.

I’ve just tested on my set up - same as listed above with Omnisphere. All patches I tested 127 velocity on the keyboard and 127 from a mouse click are the exact same level: -3db to 0db depending on the patch.
It never jumps passed that no matter how many times I click or play on a pad. Kontakt, which I use all the time behaves the same - 127 velocity is the same level regardless of if it is played or clicked.
So I am unable to duplicate your condition.

I reported it and they never got back with a fix for it. The only option they told me was to lower the velocity on each key and I did that but still get the banging noise only at a lower sound level. They need to put in a soft touch in performance modes. I was taking chords from artists performances and creating my own rather than using the chords option as it was just much easier to get creative with for me. I did find that changing it to a strum stopped the banging noise but did not fit into the song. They need to have a quick switch to change how hard or soft a chord is hit. maybe 4 different levels etc.

1 Like

Jamie yeah makes sense…but what I’m saying is i DON’T want 127 to register with a mouse click. It just needs to be adjustable within Scaler.

In kontakt, no one uses that blue keyboard to create music. However Scaler is a tool for creating specifically in this way. Having a 127 registered sound is VERY aggravating, and not useful…Who plays at 127? I might was well just bang on my keyboard. THAT WOULD BE LIKE YELLING WHEN TALKING hahaha. Anyway thank you for the responses. Hopefully David can watch the videos and better understand the issue…hopefully enough to open a feature request.

That is absolutely not right and absurdly loud you are getting a +18dBFS jump there. We can’t replicate here on PC / Mac and I’ve never seen that behaviour before. Can you please send over your Ableton Session so we can open it over and here and see what is going on? PM me a link please.


thanks for the details and video.

When testing clicking on the first chord of the chordset “Triads (I-ii-iii-IV-V)” with the first performance “Basic Perf 1” see the session screenshot below:

Then when routing the MIDI out from Scaler 2.5 (VST3) into the second track like so:

this is what clicking on the first chord gives us in term of velocities:

Is this simple scenario behaving differently on your side?

If not, then, please, in order to track down exactly what is going on could you either send us an Ableton live session or precise details about the combination that gives you that unexpected behaviour?

Side questions:
- Are you using VST or VST3 version of Scaler 2.5?
- What is the input velocity values registered into Ableton by your MIDI controller when playing soft/hard?



I should have tried this. Brilliant!

Yes as we know Scaler is registering mouse clicks at 89…which as you can see is quite harder (and thereby louder). So the request still stands to have this be adjustable, because everyone plays differently and granted I’m not going to mouseclick my composition, I still might preview a chord with a mouseclick. And if all my levels and monitors are set for how I play (medium velocity) then when it hits 89 it’s way louder than all other sounds sitting in the DAW.

I also did a mouseclick test with HUMANIZE Velocity set to ON. When clicking you can see the top notes registered way above the 89 default. 119, 115, etc, in this case.

And FWIW, I’m using VST2 BTW.

Hey thanks for your detailed look at this. Yeah I put in a feature request in recently for the same reason, although I was only noticing the 89 value by default on these as I wasn’t using the humanize at the time. Basically it would be great if the place in the code that reads that value of 89 could just read it from a config option instead, even if that new option was only in a text file it would be fine with me. For me I’d probably set it to like 55 or something like that. Here was that feature request: Would like to be able to set the velocity a newly added chord will play with when I mouse-click on it

1 Like

What you are playing in your video is audio 18dBFS above the playing on your keyboard, in terms of loudness that is three times louder. Your velocity discrepancies you are displaying here are not reflective of that loudness boost. This is almost certainly something to do with your routing / stage gaining. We would like to see your session to eliminate the slim possibility of some kind of bug you may have discovered.

1 Like

I too reported my thoughts about the default volume being too high not long after I purchased Scaler a year ago. I use Scaler in conjunction with my external synth, a Korg Kronos. The Kronos has 8 velocity layers and each layer produces a different timbre. The default volume when auditioning chords pushes the timbre to inappropriate extremes.

I my case, I switch to a less sensitive keyboard velocity curve to reduce the harsh timbres.

Yes this is understandable as you are trying to trigger a specific velocity layer so an adjustable fixed velocity makes sense but it wouldn’t resolve @KDUB 's problem or rather it would band aid an oozing wound! Let’s see if we can get this in a settings menu soon.

Hi Davide … @davide I wound up in this thread looking for a solution to this same issue. Since I am using Scaler (on this occasion) in a different way, I thought it might help to describe what I am doing. I am adding Scaler (ScalerControl) on a MidiFX slot in Mainstage. There is a 10 dB difference between when I play a chord with my midi keyboard vs. when I click on the chord with my mouse. I understand from this thread that when you click on a chord with your mouse, the chord is played at full velocity. If that’s the way it is then that’s the way it is. … and as @KDUB said, we aren’t playing a song with the mouse. :wink:

We’ve managed to integrate a Velocity Output setting in the iPad OS version so I can’t see any reason why we wouldn’t be able to integrate this into 2.6 Works very well in that it only affects the velocity output of the scaler keyboard and all chord boxes, circle of fifths chords etc.