Unable to get Scaler to work in Ableton 9 live

Hey guys I’m running 2 laptops, Both with Osx 10.10.5, one with Live 9.7 and the other with 9.0.4

And i am unable to get scaler to show up on either laptops DAW, It says that it installs fine but when i scan the plugins folder and do as the installation manual says it still fails to load Scaler or even show scaler as a plugin option within the DAW. Please help as this is extremely frustrating to me.

Hi @js_perth

thanks for reporting, sorry about the inconvenience, are you sure Ableton is setup to search for VSTs in the system folder ?


100 is definitely set up for that haha, it finds other new plugins just not your scaler.

All good then, just wanted to make sure… :wink:

Are you running Ableton9 32-bit?
Scaler 1.6 only support 64bit architecture, you can try with a 64bit version to check if it is seen properly by your DAW.


I’ve tried downloading 1.5 to see if that was the case but 1.5 doesn’t work either, also you should really have that updated in the notes that the new one only works with 64-bit. is there a way around this?

any way you guys can link me to an actual 1.5 version or 1.4?

Sorry my bad, 1.5 was also affected by this change.

We have updated the page but the info (located in the system requirements) might not be visible enough.
You can install a 64bit version of Live 9, otherwise I think you can use a “bridging” software to load a 64bit plugin in the 32bit host. I have never tried myself though but there are tutorials online on how to set it up.

I would suggest to update to a 64bit version though as your system probably supports it and it is an issue you are going to face more and more as developers are moving away from 32bit.

That’s not an option for me right now. as i only have 32 bit versions of all my plugins. There has to be away around this… and no the page info on plugin boutique made no mention of my system needing to be 64 - bit, hence why i purchased your plugin

are there any older versions you can link me too please?

I have sent you a link in a private message.

Regarding a possible workaround, I was just thinking, you could probably load Scaler in a separate 64bit host and then either drag and drop the MIDI into your 32bit host or route the MIDI outside of one DAW (x64) and into the second one (32bit).
It is not ideal and might be complicated to setup, but at least this gives you a way to use the latest feature from 1.6.

Continuing the discussion from Unable to get Scaler to work in Ableton 9 live:

Hey Buddy that link installs and everythings where it’s meant to be, it’s still not showing the plugin within my daw though

Try to manually get rid of all the .vst files in the plugin folder before installing the old version. It is possible the installer didn’t replace them properly as you had a more recent version installed.

I am having the same issue, no mention of 64 bit only can you please send the 32 bit

@FrazMcaz Hi and welcome. Scaler 2 is 64 Bit only and is advertised as such as the bottom of the product page:


I just purchased Scaler 2. Downloaded and went to open in Ableton 9, but it’s not listed in my plugins. I’m running 64-bit Mac OS and also Win10 64-bit and neither will recognize Scaler 2. Any thoughts?