Updates break existing projects with Scaler

I just updated to Scaler 1.8 (Windows VST), and now all my projects cannot find Scaler (message about missing plugin). I can obviously re-insert the plugin, but all my work in progress where I was using Scaler is now gone. Surely this is not intentional? When you update a plugin, the DAW needs to see the updated plugin as the same as the previously installed plugin, or else all current projects will be messed up. This happens to me in Live and Cakewalk by Bandlab. Thanks.

Hi @evaluna001

A user reported the same issue here about Logic Pro: Bug with 1.8.0 on Logic Pro X project saved with 1.7.0

We have been running some tests but didn’t notice the same behavior so far.

Here are a couple of things you can have a look at if you wish to help us figure out what is going on:

  • Are you sure the path to the plugin hasn’t changed, did you install new version in the same location?
  • Could it be that your project was using 32bit Scaler and now your DAW can see only the 64bit version (or the opposite)?
  • Maybe your project was using VST3 and after the update only VST2 is available for your DAW (or the opposite)?

We will continue investigating and update here if we find anything, feel free to report if you find anything on your side.


I just re-ran the install process to confirm. The existing plugin version was 64 bit VST3 (DLL named scaler_x64). I reinstalled the update, and made sure to select both VST 2 and 3 in case that was the issue. The install path was the standard 64 bit VST path that all my plugins use, including the previous version of Scaler. After installation, I opened an existing project, and got an error that Scaler was missing. I then reinstalled the previous version, and the project worked again. So to confirm, the path is the same, I installed 64 bit versions of both VST 2 and 3, and the DAW sees the update as a new plugin. I am now left unable to update and take advantage of the new features, as I have too many existing projects that will break after the update. Please assist, thanks.

Hi @evaluna001

thanks for the additional info this will be helping a lot. I will update here when I have an update about a fix or a workaround for your issue.


Hi Ed,

Thanks - I did a bit more testing this afternoon. I checked the CLSIDPlug key of Scaler 1.61 as it appears in the registry after Cakewalk’s VST scan, and then compared it with the same entry after installing 1.8. They are different, which I think explains why the new Scaler is being seen as a different plugin. Let me know if you would like screen shots of this, I can send them via email.

I am having same exact problem as noted above in Cakewalk by Bandlab. I had projects w/ the previous version of Scaler loaded, but after upgrading to 1.8 I get the “plugin missing” pop up. I can manually load the new 1.8 Scaler, but the old versions are not automatically being updated by this 1.8 version in my projects. The installation path for 1.8 is the same it’s always been for previous versions, and both 32bit and 64bit is installed, though I only ever used 64bit version in Cakewalk by Bandlab. Is there a fix yet?

Hi @boomboomchild

not yet, we will update here when we have a solution.


Given you are both using Cakewalk have you tried to delete the currently installed Scaler versions and tried to clean the plugin cache (list of CLSIDs) then install the new version and rescan your plugins ?

This file can sometimes keep duplicates CLSIDs of plugins and give some troubles when opening older sessions.

We just tried on Windows with Cakewalk from a 1.6.1 Scaler project then installed the Scaler 1.8. It works fine here, the state of the session is recalled properly.


Where is the plugin.xml file located? I don’t seem to have it on my system. Thanks.

I tried the suggestion and it did not work. I removed the old version, allowed Cakewalk to scan and remove the plugin from it’s list, then installed the new version, re-scanned and opened my existing project. Error: Missing Plugins. The following plugins are referred to by this project but could not be found. Scaler (synth rack). Please let me know what else I can try, I would like to get the upgrade working. Thanks.

Hi @evaluna001

we have been able to reproduce your issue, it seems to happen only with the VST3 version of Scaler. The VST2 in Cakewalk seems to handle the update fine.

We are still trying to find a solution to this issue.
We will check with the Cakewalk guys to see if they can assist in solving this as it is a bit unclear why Cakewalk behaves like this.

We will update here when we have more info.
Thanks for your patience.


Any word on a fix for this issue? Is there not a way to manually correct the registry key so that the DAW sees the new version as the same plugin? Thanks.

Hi @evaluna001

we haven’t been able to find a solution for this. It really seems specific to Cakewalk. You can try to correct the registry key manually and see if it helps.

In case it doesn’t work you can save your progression as a chord sets and reopen it in a new instance of Scaler after updating. It is not ideal but it might help if you can’t get Cakewalk to recognize them as the same plugin.


Are you able to provide details of which registry keys to edit, and what the values are meant to be? I have many Waves and Native Instruments plugins and none of them break on update as Scaler does. Thanks.

Yeah, I’m not convinced this is Cakewalk’s fault either as none of my other plugins have this problem when updating. Yeah you can go through every single project you have that has Scaler and save the chord sets etc and re-instantiate it and recall the preset, but is that should-be-unnecessary process going to be the case after every update?

I cannot save the chord progression in the chord set. The progression I choose in the bottom progression for some reason does not save in the chord set. According to what you say, it should, but it doesn’t. It only seems to save what doesn’t really need to be saved, the default progression at the top from the Artist or Song. You don’t really need to back them up. All you need to do is remember what song or artist you choose from the menu. I thought the save would include the progression you build at the bottom. Am I doing something wrong or is this another Cakewalk specific problem?

John B.

I just read on the Cakewalk forum that the “Missing Plugin” issue could be caused by having 2 version (VST2 and VST3) of the same plugin installed. Have you tried installing only VST2 or only VST3 ?
I don’t have access to my Windows setup right now so I can’t test, but it could be that it’s confusing the 2 versions and only one (either VST2 or 3) should be on disk.

It has never been needed before and is not needed outside of Cakewalk even for this 1.8 update. There is definitely something going on as we have been able to reproduce the issue but we haven’t figured it out yet.

We are also adding a new way to import/export the state of Scaler in the next update to prevent this from happening ever again in Cakewalk or any other DAW.

When you save a chord set from the bottom section C using the save button, it saves all the chord in your progression as a chord set.
You can then reopen from the “User” dropdown list and it opens in the section A as your it is now a treated as a chord set.

This seems to be working normally here in Cakewalk, let me know how it goes.

The import/export thing is not a bad idea

Hi Ed,
The installer does not allow the selection of VST 2 or 3 separately, it only allows selection of 32 or 64 bit, or AAX.

Yes, you can try to manually move the VST2 out of the folder and see if it works, if it doesn’t put it back and check with VST3… not sure if it is causing the issue but it could be confusing Cakewalk to see multiple versions of the same plugin.

VST2 should be under C:\Program Files\Steinberg\VSTPlugins
VST3 should be under C:\Program Files\Common Files\VST3