Using Scaler inside Blue Cat Patchworks

I recently brought Bluecats Patchworks. I’m trying to use the latest version of Scaler to send midi out inside patchworks to a synth in parallel all within Patchworks . If I set up the midi connections out from Scaler and in to the synth check that host is unchecked to none and sending on midi ch A 1 I’m not getting any triggering of midi or sound inside Patchworks. I’ve tried Scaler in both Pre and main slots with no joy. WA Instant Composer is working fine sending midi out inside Patchworks so I know it’s not a Blue Cat problem. I’m using the latest version of both plugins inside of Ableton 11. Has anyone got this to work? I checked out all the relevant videos on U tube how to set it up etc!

To be clear, have you got Instacomposer (hosted in Patchworks) to send midi to separate tracks in Live so that each track in Live can host an appropriate instrument ?

@yorkeman Yes I managed to use instant composer inside Patchworks to send out to different midi channels and going to different synths but that’s not what I was trying to achieve. I wanted just to use Scaler to send out to a synth within patchworks.

I’ve not found a way to do this in Patchwork .By “this” I mean

1 Load Instacomposer into Patchwork

2 Assign the midi from each track to a separate output port (it has to be a port because Live has no channel recognition)

3 (what I have not found a way to do) associate the output port (A, B, C etc) in Patchwork to a system visible midi port as an ‘OUT’

4 In Live, assign the input to a track as being from the corresponding ‘IN’ port, so enable it to separately play a VST in each of 5 tracks.

There are multiple other ways to achieve with this without Patchwork which are cheaper (and some free) without the the opaqueness of the Patchwork interface, so I abandoned the attempt.

I guess I should have read the manual. However, I sort of have the same approach as friend @ClaudioPorcellana, which in the words of the introduction in the LINE 6 XTPod rack manual are “Manual ? I don’t need no stinking manual !”

1 Like

You don’t say if you are on a Mac or PC. This is in Live 11 on Mac with Patchwork on a MIDI track and it works fine. VST versions of both Scaler and Zebra.



Hi @jamieh

First off thanks for taking the time to screenshot that. I’m on a MBP using Ableton. I tried the setup you shown the only thing different was instead of all channels selected I had port A selected on the output from Scaler and input into the synth of my choice to channel one.Our give it another go later selecting all channels. Again many thanks.

Are you using the VST or VST3 version on Scaler? AU doesn’t pass MIDI info.

1 Like

Hi I got it half working now using VST version of Scaler rather than AU components version so thanks for that. The only thing I can’t get to work is midi into Scaler via my Arturia Keystep. I can’t get scaler within Bluecat patchworks to receive midi in. I tried disconnecting the keyboard It’s recognised in Live works with other VSTs. I tried sending in via host and or ticked none and tried via Port A all channels. I can’t seem to get midi into Scaler but if I trigger Scaler pad or keyboard with my mouse it’s now sending out to a different vst.

Scaler should be set to Host All Channels. Out of Scaler = Port A - All.
What channel is your keyboard sending on? If you just have an instrument on a track (not Patchwork) the keyboard works fine? If you set Scaler on a track does the keyboard play that?