Using Scaler midi effect in Logic to control / record Kontakt instrument


I’m working through the Scaler official course. Maybe this will be covered, but I could use an answer now for a project I’m on!

I’m using the midi effect plug in in the latest Logic to control a Komplete instrument. It all plays fine, but the midi isn’t being recorded into the track.

If I play the instrument via my keyboard all records perfectly. I’m just not getting a recorded track using Scaler.

Is there something obvious I’m doing wrong?


What you’re asking is really a Logic question and not related to Scaler 2.x per se.

Have you turned on the ‘Record MIDI to Track Here’ option? If you highlight the Scaler MIDI FX plugin and click the right-hand disclosure triangle a list is displayed and this option is the last. A ‘yellow line’ will appear under the Scaler MIDI FX plugin in the MIDI FX channel strip chain that you have for the Komplete instrument. Now your Scaler 2 MIDI should record fine…

Thank-you, Simon. That did it. I haven’t used the midi fx too much in Logic. Thanks for the tip.


1 Like

No problem we’re all here to help each other have fun making music. It’s actually a relatively new feature - that Record MIDI to Track Here’ option - maybe only available for about 12 months or so…

I’ll take the opportunity to plug my own haha. I record as Anacrusis in Thailand and can be found on all online music streaming services and Bandcamp

Just listened to Sound The Alarm. Great stuff and glad you’re finding a wider audience.

I don’t have much online, other than the YouTube video below.

It’s a fixed up recording of a band lighting rehearsal, so def bootleg :joy:[:joy:

Thanks again for your help.