Ventura OS bugs?

I was using Scaler 2 and after a while I got a hung midi note, but the Midi panic is not making any difference?

Then I noticed all other instances (on different channels) were also firing out a random low note.

I tried Midi Capture to drag the midi and edit the low note out but then realised that wasn’t working either.

I’m assuming these are Ventura bugs as everything worked fine before update.

Welcome to the forum @Ctrl We are not supporting Ventura as it’s a brand new OS - I personally will get to install Ventura soon and test, my guess is Scaler works as per Monterey, stand alone should be fine and MIDI FX in Logic Pro X will work under Rosetta: How to run Logic Pro using Rosetta?
Any other users tried Scaler in other DAWs on Ventura?

I recently installed a new update which changed to Ventura. It doesn’t work reliably. Unfortunately, I haven’t gotten around to testing the 2.7 version yet, because I’ve been busy with other things. Only yesterday for the first time. That synchronized live feature is a nice addition. It makes things a lot easier.

Scaler 2.6 works fine on Ventura on Logic Pro X 10.7.5 in Rosetta mode (latest version with MIDI improvements, and previous ones), but Scaler instrument crashes on Logic Pro X 10.7.5.

Looking forward to test 2.7 soon, and I will provide an update.

It’s a shame that we still have this culture with music where new operating systems are seen as a negative thing and people are expected to always stay trapped in older OS to feel like they are able to simply use what they pay for.

I don’t mean this as a direct dig as I love Scaler, I just feel for the price I should be able to enjoy that AND the latest OS features at the same time rather than one or the other.

And I know Scaler has a small team so it’s a different story to say Waves or something, but I just feel like the Pro Tools era of “Don’t ever upgrade” needs to go. It’s 2022, I just want to enjoy progress and growth ha.

Rant over, hopefully there will be support sooner rather than later as it really is a great OS so far.

I get it, but here’s a list of all plugin manufactures as of today including their policy on Ventura. And it’s no surprise that not one has provided info or recommends updating to Ventura! Not even Waves.
Music producers generally run one year behind OS unless it’s a hardware forced issue. I found that the larger the software company the less likely they are to offer updates, Look at NI - Maschine and Komplete Kontrol have just got M1 updates yesterday!
That’s not to say we won’t work on that, but hundreds of hours have been dedicated to 2.7 and it’s features and content by lots of people. I will try Ventura over the weekend on one of my laptops and lets keep this thread open to reports on how we are doing so DEV’s can address Ventura compatibility (if it’s already not!)

Tho I appreciate the list, however near on all of the plugins I have from said companies are running fine in Ventura. So though they might not have declared official support most don’t need to as there are not problems.

Also this seems to be a bug that spans multiple OS as seen here Scaler 2.5 Logic 10.7.1 macOS Monterey MIDI FX Stuck Ghost Note UNUSABLE! - #17 by Ctrl so I don’t know how far we’re supposed to roll back our OS?

Also, we could put it down to personal preference. But as a fairly successful music producer that works on CPU heavy projects I personally I want the best optimisation for the M1/M2 systems which as now used in majority of high end studios I’ve been in lately. But most importantly myself and many others update for security reasons, and I think it’s important to support those that do (esp with the IOS app, updates are essential at times).

But again, I’m a fan and respect your opinion. Just there are people with new Mac’s wanting to use your software. I want to show others how great it is, but it’s a little embarrassing when I can’t explain why it’s triggering random notes during a writing session thats all.

There are two issues here, the M1 Bug is something that is not resolvable without Apple supplying a fix which we would have expected by now. The work around is launching in Rosetta. Remember this is only related to MIDI FX in Logic on M1 Macs. Instruments in Logic and all other DAWs work fine. Please let’s keep this thread to Ventura compatibility.

Could you please share which M1 bug you are talking about? I have asked about that previously in other threads, but I have not got an answer. I am asking, because I would like to help you with fixing :slight_smile:

The M1 Bug is that 3rd Party MIDI plugins are broken in Logic. This needs to be addressed at Apple level.

I know that, I will need to have more details to help out :slight_smile:

1 Like

Thank you so much for sharing that!

I have just reviewed JUCE source code and it looks good to me :slight_smile:

1 Like

Scaler 2.7 Instrument working as normal natively for me on Ventura In Ableton, Studio One and Logic Pro X. MIDI FX in Logic requires rosetta for stability. So I am not seeing any change between how it works on Ventura as opposed to Monterey.