View size increases each time I open Scaler 2

Each time I open the Scaler 2.0.8 VST3 device in Ableton Live 10.1.14 the view size increases by itself. Here are a few successive screenshots of what I see after closing and reopening the Scaler 2 window:

I’ve set it to 1200x840 as the default, but each time I go to reopen it the view size increases. I was using Scaler 2.0.7 and was having this issue there as well. I just tried upgrading but that didn’t solve it.

Please let me know if you need any further details from me.

Hi @iconseq,

Could you provide us your screen resolution and scale factor and HiDPI settings you are using ? Does it persist if you set your windows scale factor of 100% ?


I’m running the Windows 10 Education Build 18363. I use 125% custom scaling for Windows on a 3440x1440 display with Live also set at 125% zoom. Within Live, HiDPI mode is disabled and the option to “Auto-Scale Plugin Window” is unchecked.

The issue does appear to go away when using 100% scaling for Windows, but obviously a more permanent solution is what I’m looking for. Thanks!

Hi @iconseq, thanks for testing, could you have a look at this please ?

High-DPI monitor support (Windows 10)


Sorry, I’m not sure what exactly I’m supposed to take a look at there. I understand that Windows has additional settings for HiDPI support. However, to be clear, the issue is that the view size increases each time I open the Scaler 2 window. So, for example, it might start off at 1200x840. Then I close the window and open it again and it is at some larger custom view size (as you can see in the second screenshot of the Scaler 2 preferences). Then I close the window and open it another time and it again is at some even larger custom view size (as seen in the third screenshot). I don’t have display problems with any other VST2 or VST3 plugins.

If it at all helps, here are screenshots of my Windows scaling settings.

Capture 3

I think he is referring to lives scaling options.
Right click on scaler in your live plugins browser & deselect auto-scale then open scaler.

It already is unchecked and I had previously mentioned that above.

Maybe I should take a screen capture video of this in order to show the behavior I’m experiencing.

Hi there.,.just wondering if you had figured out a solution. I’m having the exact same issue. It’s like scaler 2 is magnified everytime i launch.

It’s so large I can’t close the inital screen to get to the vst

Hi @iconseq

thanks for reporting, it looks like a calculation is wrong somewhere, I haven’t been able to reproduce your issue yet on my test machine but we are still investigating.

Hi @kemo

Have you tried enabling/disabling the UI-Scaling or HiDPI support in your DAW or even Windows temporarily?

DAWs sometimes allow you to disable it per plugin and it might solve your issue and allow you to pass this first screen. Then you should be able to manually set the default size of Scaler in the settings.

Let me know if that helps,

@Ed1 I’m just bumping this again because it’s still not resolved as of Scaler 2.0.9. So, right now neither the VST2 or the VST3 plugins work for me. The VST2 has display issues as well, which is a separate problem that I made a separate post for, and it was suggested there by you that I use the VST3 instead. Unfortunately, the VST3 doesn’t work either.

I’d like to get an honest assessment of when you are going to get this resolved. I can’t be the only person with this problem. These issues look to be related to how scaling is handled on Windows 10. Was that not a consideration when you were developing and testing? Why did you release a product that wasn’t developed for and tested across a variety of platforms and settings?

No other plugin that I own has exhibited these issues. You’re alone in that respect. Just a simple acknowledgement that these are problems and that you’re working on fixing them in a timely manner would suffice. In lieu of that, this is a broken piece of software.

1 Like

Hi ,

I am also having these issues with scaler2 since ver.2.04.(currently installed 2.09)

windows 10 1909, 4k screen, windows scaling set to 150%, ableton live 10 (125% zoom).

Also wanted to mention that scaler1 worked without any issues on my system with identical settings so there must be something wrong with the gui of scaler2.

Hope this gets resolved soon since this is a great plugin otherwise. :slightly_frowning_face:



Hey @iconseq & @scalernotscaling

sorry you are still experiencing this. We haven’t found a way to fix it yet. I don’t have a precise date to communicate but we are working on it.

Thanks for your patience,


1 Like

@Ed1 I’m glad to say that as of Scaler 2.1, I am no longer encountering this issue. I can’t speak for everyone, but the scaling problems have been fixed for my system. Thank you for your work and the work of the rest of the team in addressing it.