Warning: Scaler is crashing Reaper

I downloaded and installed the latest version of Scaler last week, and it opened and it seemed to work fine in Reaper.
However, I close/save the project and come back next day and Reaper tries to open the project and fails. It just crashes and exits, no error or warning.

I then deleted the Scaler DLL (64 bit version) and then reloaded the project and it loaded up no problem.
I’m going to keep my eye on this but just wanted to inform you guys.
(you can get a fully functioning trail of Reaper from cockos reaper.fm to test it if u like.)


thanks for reporting this, if you have the problem again, it would help to send the reaper project so we can have a look.


Here it is

Thanks @MasterTuner,

I have been trying a few things on Reaper but I couldn’t reproduce your issue. The project seems to open fine every time.

Have you reinstalled Scaler and did it fix the crash? Let me know if you experience this issue again.


I have a workaround: This happened to me on Reaper 6x Win 10 home. The problem was I installed Scaler into vstdir/Plugin Boutique/ instead of just vstdir. I guess Scaler doesn’t like custom directories and has to stay in the root vst dir.

After uninstalling I reinstalled in vst root directory and it worked great.

Weirdly enough, in Ableton (which I also have) it also worked fine in the custom directory.

Hope this helps other Reaper users!