What i hate for scaler 2

when i drag my main chord to scaler and record midi from scaler to drag it
first thing i will wait until finish the record
the second thing is more important to me
when i drag the midi is not the same duration why ?
only if i make it manually this thing in EZKeys much better
any solution ?

any solution ? i want it automatic fill my midi event i copied and paste from my main chord and try to change the technique after that when i paste the new one its shorter !!!

I can’t understand exactly what the problem is and how you are taking MIDI to the DAW from Scaler. You explanation is very hard to understand.

  1. Is Scaler in sync with your DAW?
  2. Are you drag and dropping the pads from Scaler or do are your recording MIDI into the DAW per track?
    I can’t see enough of you Scaler Screen to really sus out anything here.
    Scaler won’t fill out a track based on any number of reasons. If your pattern is not timed correctly to do that. The main beat settings and each pad setting determines how long the MIDI is for each pad. Can you share that info?

hello i record my main chord in cubase without scaler then i copied my main chord to scaler i want only change the perform style then i record again my chord from scaler to drag it again in new track but the length is not the same if u still didnt understand i will share the pics because english isnot my mother language

First I copied the basic chords from cubase to scaler

I played them with scaler with small play button to midi-capture then I re-drag it in new track , the problem is that they are not the same duplicates or the same size

The most important thing you need to know here is Scaler does not detect timing information at all. You need to adjust that in the DAW or adjust it manually in Scaler.
Scaler timing depends on the Beat global settings and the pad timing under edit. Scaler was never intended to respond in the way you are trying so it’s not a bug it’s just the way it works.

Scaler does NOT detect timing information! Global Beat setting controls beats per chord (PAD).
Under the gear on the upper right is the Global Beats settings - Here I have it set for 8 beats.
Under edit I have the first chord pad set for X1 which means that pad is set for 8 beats so if you drag and drop the MIDI from that pad it will be 2 measures long (4 beats per measure at 4/4 Timing) —

Setting the Pad for X2 in this case makes the drag and dropped MIDI 4 measures long —

thank u for ur explanation :rose: