Wrong notes after playing midi

Logic Pro 10.6.3
Scaler 2.4.0

Hi there, I have a pretty weird behaviour in Logic Pro. Once I bind my MIDI keyboard to Scaler section C, everything works as expected. After recording the MIDI, there are some weird notes in my chords when I play the recorded region. Sounds like they are not even chords. It’s strange since it works perfectly in Ableton. The next strange thing is, that it’s broken just for some chords - a few work, a few don’t. Please help :slight_smile:

Thanks a lot!

P.S.: When I switch off the binding, I have no chord on my midi keyboard but on some (!) notes from the piano roll. It’s kind of mixed up.

Hi @PhilPhiera

thanks for reporting your issue.

Could you give us more info on what you are trying to play (performance, chord, notes) and how you are recording the MIDI (drag and drop, MIDI-Capture,…)?

It seems to work in Ableton, have you tried routing the MIDI out of Scaler into another track and recording the MIDI there? Is it any better?

Don’t hesitate to add screenshots or even a short video of the problem, it helps a lot.


Hi Ed,

thanks for the fast response. Now - this is more than awkward, I restarted my Mac today and now it works. I’ll try to reproduce the error and take a video :slight_smile:

Was recording via MIDI-Capture and have tried different tracks and also opened the MIDI FX as well as the ‘full’ plugin. Was broken at any time.

Will take a closer look later today.

Best regards

1 Like