2midi files created

when i drag the file from scaler 2 it creates always 2 midi files in cubase , no matter what instrument or track. is there any solution

I have Cubase 11 on a Mac and I’ve never seen this behavior. What system and versions are you using?

i am using cubase 11 on pc all updated

i read somewhere else in the forums that others had the same problem as me but i cant remember exactly where i read this .

Yes, I have the same issue in Reaper.

Others appear to have the same problem as me.

quite surprisingly, it also happens when I drag & drop a MIDI from Scaler to EZkeys BEFORE passing first the MIDI in the EZkeys Favorite section

Hi Jaikez

I’m not sure if you are referring to Scaler or Cubase here, as you didn’t state which application might be the source of the problem (apparent memory loss) . You have actually provided very little information about the environment of the problem for a vendor to investigate.
If your invective is targeted towards Scaler, with respect that I suggest that bulletin boards serve the interest of users best if the contributors use balanced and objective language.
If this is the first report of the problem with Cubase, you made this post 5 hours ago, and appear surprised that it hasn’t been fixed yet. It may be that your best solution is to cease use of this ‘cruddy’ software provided by an unresponsive vendor who doesn’t give a ‘crap’ and seek an alternative provider with which there are no such issues - but good luck with that; I fear your disappointment will continue.

1 Like

well, it is not the case of Scaler
and BTW I don’t think that having to remove 1 of 2 useful items can be considered a severe bug…

1 Like

Have you checked this Cubase problem fix?

Still not enough info. Operating system is not listed. When you say there are 2 files - are the files stacked on top of each other or on 2 tracks or…? Are you drag from the chord pad or recording a chord sequence and using the drag box in section C?
For me Cubase always creates a new MIDI track instead of dropping it on the track I want. I need to change a setting for that I think.

jamieh IN Cubase Go to preferences , midi import options, then under destination chose instrument tracks , it likely wont make any difference if you chose auto dissolve format 0 or uncheck it … Also under preferences import midi file make sure to check = Import Dropped File as a single Part… That should solve your issue of dropping it on the track you want instead of creating a new midi file … My issue is on the instrument track it creates 2 midi files . one on top of each other… and it doesnt matter what the destination i chose , in cubase for example if its a midi track or instrument track, always the same thing … 2 midi files , one of top of the other… Also i use many other plug ins and am constantly dragging midi files all over the place in cubase even from ez keys internal . and i never get 2 midi files… I even drag midi files from windows explorer into cubase and i only get one midi file,.
But once i again i maintain that in other posts in these forums people claim to have the exact same problem as i have , it appears to be a known issue for some time and apparently has no solution …
Oh and it doesnt matter where i drag from Scaler 2 even its its only one chord, the same result is 2 midi files one on top of the other…
My operating system is windows 10 , updated all patches applied , etc etc
Even someone else on this same topic has the same issue … scroll up


Yes, I have the same issue in Reaper.

1 Like

Hi @jaikez and thank you for reporting your issue.

you are right, it has been reported before. It is on the to-do list, the reason it hasn’t been addressed yet is that we have prioritized fixing other bugs that were affecting more users.

The way we see it is simple, it only affects some DAWs on Windows, only if you use the drag and drop feature and Scaler still generates the correct notes.

There were some more serious bugs/crashes that have been fixed recently. With the latest update (2.3.1) we are now at a point where Scaler is a lot more stable which will allow us to focus on other issues like the one you reported.

Thanks for your feedback,


@jaikez Thanks for the info.
Does the Delete Doubles Command in Cubase work for the situation you are having? Or does that just remove doubled notes in the same file?

thanks Ed1 for the reply . HeaveN Is JusTiCe by JaiKeZ | Jai Ke Z | Free Listening on SoundCloud

Yeah I get the same thing but it seems intermittent for some reason. Sometimes I get the double MIDI clip and sometimes I don’t. Happened sometimes in Tracktion Waveform and Samplitude as well if memory serves. I usually drag the clips into place after I drag them out of Scaler so for me it’s obvious right away and I just delete one.

I reported this awhile back that this also occurs in Cakewalk Platinum. It seems to execute 2 paste operations. This causes issues with editing and moving clips as you have to make sure to delete the extra clip.

This happens in Logic too, not pc only.

Are you sure, send a video because we use Logic and Scaler across many Macs and OS’ and never had double midi