A lot of notes are missing in MIDI capture

Hi! I use Scaler 2 to capture performances.

I bind section C, turn on performance, capture midi, and drag it to my DAW.

Already tried Ableton 11 and Nuendo 11 - both midi clips have missing notes and chords.

I dragged midi to other instruments, also tried on Scaler track (I know and turned off performance and bindings during playback on scaler2 track).

No luck, it is visually visible that something works wrong…

A lot of notes in chords and performance are just missing. This happens when using a midi keyboard. When I pres chords in scaler 2 with the mouse it seems to drag that midi well.

But I want to use my midi keyboard (Native Instruments A49). Also tried another midi via iPad+loopMidi+LK - the same problem.

Please help me to solve this!!

Without a comparison screen shot of what is correct and what is missing it’s hard to tell what is going on. You also don’t list the Computer OS nor the Scaler version.

I use Windows 10, last updates. Scaler 2.3.1.

The empty area in between notes shows that the notes are missing - but they need to be there.

I was hearing and seeing expressions played by scaler, but this is what it looks like after I drag it to DAW.

Playing any expression in Scaler always triggers melody notes, but they are missing here…

Also, some long notes of chords appear, which are also out of place.

Welcome Al

I do a ton of midi capture and loss like that is odd. My bet is it is related to settings in Scaler. I drive a lot of fast staccato instruments as well as percussion via samplers so I’m constantly midi capturing PERFORM mode @ x2 speed while playing notes via KeyLock as well as key switches. I’ve also torture tested Scaler’s midi capture capacity to hundreds of thousands of perfectly captured notes I’m pushing midi capture pretty hard and I’ve never seen similar midi drops. That being said, the actual keyboard entries I play are probably fewer than someone that actually plays.

If you start with a clean and simple Scaler setup and replicate the dropped notes scenario details, it will certainly help others lend a hand. Some screen shots of your Scaler setup and Playback Settings pane would also help

A couple things to consider

  • Be sure you explore all the Scaler playback settings as they can certainly impact what your are hearing/capturing. It took me a while to sort through what was interacting with what and I’m still not always 100% sure what I have set when. Be sure to look at Play Quantize, Chords Only, Chord Mute
    *For example if you have Play Quantize turned on in settings and you don’t have your keyboard bound, in certain cases, any notes not played perfectly in time will not be played. Depending on what you are playing this might be hard to detect in real time.

The image below is a simple example. I have Play Quantize turned on and PERFORM Arpeggio mode turned on @ 1/4. No patterns or or chords are playing. The brown midi capture is me just tapping a note at a quick pace but notice only the notes that are timed perfectly are captured. (when you 1st start it can seem like the keyboard is not even working) The green box is the exact same procedure with the keyboard bound. and all notes are captured . Had I a more complex PERFORM mode enabled, the same thing would happen it would just be harder to detect. (BTW, this is a great way to work on keyboard tempo)


Anyway, this certainly might not be your issue, but it might help you narrow down your scenario. Scaler is a really solid tool, I think you’ll get this mystery solved.