Ableton Routing Midi Whilst Composing in Scaler



I’m using Scaler 2 to create chord progressions, and I want to trigger another VST instrument in a different track to play back those chords while composing. I’ve set up the MIDI routing by using the “MIDI From” option to receive MIDI from the Scaler track to the target track, which works fine when I drag MIDI info into a clip on the Scaler track. However, it doesn’t seem to send MIDI when I’m just playing with the chords within the Scaler plugin itself.

Desired Behavior: I’d like the MIDI to be sent from Scaler 2 to the target track in real-time while I’m playing with the chords directly in the Scaler plugin, without the need to drag MIDI clips into the track.

Setup Details:

  • I’m using Ableton 11
  • Scaler 2 is running as a VST instrument on a MIDI track.
  • The target instrument is on a different MIDI track.
  • MIDI routing is set up correctly, and “MIDI From” is set to receive from the Scaler track.

Question: Is there a specific setting or configuration I’m missing to ensure that Scaler 2 sends MIDI in real-time when playing with chords directly in the plugin?

I’d appreciate any guidance or insights on how to resolve this issue. Thank you!

Two things -
1] MIDI from is set to Scaler as you said and right under that where is will say Post FX set that for Scaler as well.

2] And most important set the Monitor of the instrument track to IN


Hi Jamieh,

Thank you for your help so far.

I tried to follow your instruction. But for me the only 2 options I have in that lower dropdown are PostFX and PreFX. What am I doing wrong?

Many thanks

Image with dropdown visible

This is rather odd; here’s what happens when I do this

The only way I can get what you show is if the piano was loaded, but Scaler had not yet been loaded into the track… but of course as the track is labelled ‘scaler’ that’ what shows in the MIDI from.

BTW, ae you on Mac of PC ? That’s helps responders …

On your drop down and also on the Scaler track it says Scaler. It should Say Scaler 2 if you are using the latest version. You also don’t say if you are using Mac or Windows but if you are on Mac and using the AU version you will not see Scaler in the PreFX Drop down. You should be using the VST or the VST3 version of Scaler for the routing to work. The AU version of Scaler cannot route MIDI to the instrument track.
Screen Shot 2023-10-26 at 8.50.54 AM

You should see Scaler2 in the VST list and Scaler 2 in the VST3 list -----
Screen Shot 2023-10-26 at 8.40.36 AM
Screen Shot 2023-10-26 at 8.40.55 AM

In my screen shot where it says Scaler, that is version one and it looks like that is what it looks like you are using. Do you not see Scaler 2 under plugins? You should be using version 2.