Are you leaving MIDI notes on the table? How the Chord Duration setting impacts playback

While apparent to many but probably not all, did you know not all Scaler Performance modes are created equal? By that I’m referring to the length of the Scaler Performance midi sequence as controlled by the Chord Duration setting in Settings/Playback

For example, these 3 midi clips are just the Cmaj chord accessed via drag and drop with the different Chord Durations set. This is the Rock1 Bass performance shown with the Chord Durations set to 4, 8 and 16 beats.

Since the pattern does not repeat until 16 beats, each duration setting delivers a different playback. If I had never played with Chord Duration, I would have missed half the performance.

Contrast that to the Basic1 Bass Performance:

You can see the pattern repeats @ 4 beats meaning you would get no variation across chord durations

Once I understood this, a number of things made more sense including why Pad Edit / Payback Timings / Duration timings were at the increments they are.

Again…probably obvious to many but maybe not to all.

Happy Holidays!


Quite right some are two some are four and some are eight bars long. Some really nice variations. I lawns sit on a chord for a while just to check it’s full content.


I certainly noticed this before. A related function is the Performance Mode which is accessed in the “Settings”. It can be retrigger or follow. retrigger with start the pattern from the top with every key press while follow, will allow the pattern to continue on into the next chord change. It’s easier to understand when you tinker with it than trying to describe in text.

One thought I had while reading this is maybe all the various performances could benefit from just having their entire length shown in parathesis at the end of their name. Like “Basic 1 (8)” for 8 beats?

1 Like

I agree with the beat notation. My memory is just not good enough to remember which are which. :slight_smile:

The Follow/Retrigger certainly adds some interesting options. However, I play the mapped chords in perfrom mode in Play Quantize mode and have not been able to figure a way to utilize the feature.

As far as I can tell, it is only active when a pattern is in Scaler’s playback mode or maybe being triggered from an incoming midi stream (not sure on that). I’d love to play the keys directly and get the Performance Mode setting to make a difference but so far, no joy. Maybe I’m missing something.

Agreed! The number of beats would help.

Do you mean you’re clicking on the chord “buttons” with a mouse? I typically using Section C, set up an arrangement there, or a series of arrangements. And then either export the MIDI from Scaler into my DAW or capture it in real time in my DAW. So working that way the follow mode works as expected.

Not usually but sometimes.

I typically create several chord patterns in the pad and then map different chords with different playback performance settings. I mix and match styles, playback speeds, octaves, voicings etc and bind them all so I have a keyboard full of varied performance parts and pieces.

Then I enable Play Quantize for Expressions, set my Chord Duration to 1/2 and Play Quantize to Chord length. At that point I can start playing the keyboard (in my very novice way) letting Scaler play it’s performances in time.

Playing with Play Quantize takes a little getting used to and requires a couple settings to be right, but I find it an amazing way to create some really interesting stuff. (at least to me :slight_smile: ) If I’m really feeling ambitious, I’ll drive a Synth like Arturia Pigments using some of It’s Sequence patches. Thats when the fun really starts.


Ah, now I understand what you’re saying. I thought the follow or retrigger would in that instance but maybe not. I can never really remember to be honest. But I know I use the follow often. Maybe it’s because what I typically do when “playing” in the notes to trigger the pads (MIDI input bound to section C) is I record my input to scaler as a track in Cubase and then quantize that MIDI data inside of Cubase rather than asking Scaler to do it? I don’t know if that makes a difference or not. Maybe worth a shot to see if that makes a difference for you.

1 Like