Audio detection not working in ableton

Hi there, i cant get the audio detection working in ableton. When i drag a file it says the detection will be replaced then i press yes but when i hit record nothing happens. Also if i have an audio file playing and i see the visualisation on scaler but it just says " waiting for input"
what can i do?

Hello, Robert. Welcome.
Maybe you are trying to make it detect audio with Scaler2 and not with Scaler2 Audio
Scaler 2 is a midi instrument and Scaler 2 Audio is a vst that is placed as an audio effect, on the track where the audio is
Try if it’s worth it

According to the manual you are wrong, it should be possible to detect audio with the midi scaler 2. Set source to audio and drag an audio file to scaler, or send it per sidechain.
But - it doesn’t work… :frowning:

I tried to repro this. I have Ableton Live 10. Using “regular” Scaler 2 plugin (VST, 64bit, and also VST3), I could drag an .mp3 music file from Windows Explorer into Scaler, within Ableton, and it automatically extracted chords.

What version of Ableton are you running, @robert , and what computer/operating system platform?

The other thing I could think of why it’s not recording from an audio feed, is that the audio input level is not triggering the threshold in Scaler, which you can actually adjust. Look at your level meter while playing audio into Scaler, if it ever crosses the blue dot on the right side…

And regarding which Scaler version to use (MIDI/Audio), I think that has to do with how your DAW routes audio streams.
So to repro @robert 's scenario, in Ableton I used the Scaler Audio plugin to pipe the MP3 soundtrack from another Ableton audio track. Here’s a screenshot from how it worked in my environment (Windows 8.1 x64, Ableton Live 10 Lite)


Well. I only said it to help. This is how I use it and it works for me. If it’s better for you the other way, do it that way

Also having this problem.
Ableton 11.0

Just sits there and doesnt’ do anything, even the input level meter is showing audio. Tried lots of different audio, nada.

Hey @mafgar & @robert

would you mind sharing one or a couple of files you have tried that didn’t work. It will be useful for us to diagnose what is going on.

If the audio content does not make sense to Scaler (ie: too dissonant, too noisy… ) it will not detect anything.

Is there any file at all that gets detected? Can you try with this one: