Bought Scaler 2 and was completely broken (Beatport Access Authentication)

Im so dissapointed in this new Beat Port authentication as the app is completely broken as well as scaler 2. I have the scaler 2.8.2 download as it is the only one available to download, and after installing it and loading it on Ableton it tells me I need Beat Port open to access it.

Of course, in the website there is no where or even a google search to find this beat port access download. I found it with one of my cancelled subscriptions with beatport. So I downloaded it which seems to be the latest version and I see my product but cannot register it since it crashed anytime I click the key button or how to install, nor will it change the plugins access within ableton. No way at all does this startup match the installation instruction on the site, I cant even open the plug in and attempt to register it with the product key. So at the moment I feel like Im down $49 cause I have no way of using scaler 2 since the installation instructions on the site is outdated or the app is completely broken… or both! Please send help I tried multiple reinstallations of both scaler 2 and plugin botique including deleting all remaining folders and of course tried restarting my PC and DAW

1 Like

Here is what my beatport app looks like

Solved by delete appdata files for both pluginbotique and Scaler 2 after uninstalling the apps. Rebooted and reinstalled just scaler 2

1 Like

Can confirm this has also worked for me. I had the Exact same issue! I had the Rent-To-Own from Plugin Boutique originally and decided to purchase it in full, canceling the Rent-To-Own subscription. Beatport Access failed to activate Scaler 2 from that point forwards, for months.

This was a horrible process and one of the worst experiences I have ever had with software. I own over 10k worth of software on multiple platforms and publishers, all the way down to just the iPad, which also has Scaler 2 on it and I love it.

This needs reworked. I have left a 1 star review for this app on Plugin Boutique solely because of this issue. There needs to be a more streamlined process for users that want to go this route or this needs to be stopped as an option completely. This has made me have a horrible view of Beatport and is something i can not recommend to anyone until more thought is put into this workflow.

Thank you so much user JAYNANDEZ for having this post here. I have spent a week total getting to this point and seeing this post. I hope others find this quicker than I did. You have helped me regain my sanity.


HI @lamardoss and @jaynandez Sorry to hear about these issues they don’t sound great. Please bear in mind that Beatport access is controlled and run by Beatport and Plugin Boutique. It has nothing to do with us (Scaler Music). I’d encourage anyone having issues to lodge a ticket with PIB. I will forward this thread to some seniors at PIB as I don’t want bad reviews left for Scaler 2 when it has done nothing wrong.


Thank you. I have a ticket open with PB already and have not yet gotten a reply to it for some reason. I do have a ticket number as well.

I’m not sure why, but this issue only happened to me when trying to activate Scaler 2. I have many more plugins within Beatport Access that are working correctly and activated. So to be blunt, I’m not convinced this is just a Plugin Boutique or Beatport Access issue, hence the review given.

Even if Scaler 2 isn’t at fault for this, then Scaler 2 needs to stop installs and activation options from Beatport Access. There is a very clear problem between the two apps and Scaler 2 needs to use different methods until this is fixed.

There are MANY users that are having issues with getting these two programs to talk to each other with various issues and it seems to have been that way for a long time.

Scaler Music, please stop using Beatport Access. Scaler 2 is not worth the hassle we are having to go through.

1 Like

after reading these threads on Beatport, i’m glad it wasn’t available for me (without a paid subscription) as it seems like a beta product. based on several other forums, Scaler isn’t the only product experiencing severe issues with downloading and installation.

probably the best bet - remove Beatport (if you can) and download directly and install yourself.


Hi everyone and @jaynandez,

Hope you’re all keeping well!

I am very sorry to hear about these problems.

For anyone who may be experiencing issues similar to this one and hasn’t yet done so, please contact our Customer Care team via our contact form and we’ll be more than happy to assist in resolving anything that requires attention.

We’re currently working through a backlog of tickets and are working hard to get back to those of you who have already sent us a ticket request.

Apologies for any inconvenience caused and thank you for your patience and understanding.

Best wishes,

Thomas Webb

Head of Customer Experience
Plugin Boutique


Also just to clarify to all that Beatport Access is only required if you are running a Rent To Own plan or accessing Scaler 2 via Beatport Studio. Otherwise please don’t worry about Beatport access and download from the Plugin Boutique, My Account and install as normal!

Thanks for the response Davide and although I appreciate you reading my ticket and responding here (and next time if it is beatport related and not happening withing the Scaler app I will send a thread there), this was affecting the Scaler app. If you see the screenshots the app was not letting me bypass this at all which is clearly built in to the application, and so a legitimate argument is to be made here about Scaler and its initial set up especially if you previously had it as rent-to-own. I have taken the time to figure it out and share this information with others when I believe there could be more clear direction on removing the appdata files for both scaler and pluinbotique as it is a mandatory download for the rent-to-own. My review on Scaler 2 itself is actually great, its works well, its powerful and actually very creative I think every producer should have this in their back pocket. Just hoping there can be an easier workaround for when someone goes from rent-to-own to owning it.

1 Like

So glad this worked for you too, I know I spent HOURS researching this so I can imagine months for something YOU PAID for. Thanks for sharing this and how it turned out for you!

1 Like