Bugs after bugs after bugs

  1. Auto key detection never been sooo off. Midi and Audio
  2. When you sync Scaler with host, you should have a simple way to choose the duration of individual chord… i can only choose with what das 0.33 beat mean?
  3. When the White key-log is been used, and you want to change the section, it moves mirrored. that is soo confusing
  4. the option sync to daw should be some way in from not hidden in the settings. instead of informing me the host ist stopped.
  5. i heard in some clips of scaler 2 that you can choose how the keys should be writen (A#vs Gb). I cant find it.
  6. When you record with the midi bind, my scaler cant seem to catch the timing right.
  7. In combination with 6. and 1. having the chords mapped out and bind, when played back everything is off.
  8. When synced to host in playback form, it does not automatically continue on second page… third ect.
  9. When synced to host, loop playback is not clickable.
    i could go on and on and on…

but honestly, this upgrade is only in theory useful … and i am mad. The problem is not on my computer everything else is working perfectly fine. i might have had 1-2 settings, wrong but they are not as much settings options to explain all bugs listed. not even half.

We need ASAP an Update or the money for it is absolutely not worth it.

btw, i work with Studio 1 4.6 and windows 10 64bit…

Hi @masika welcome and thank you for your detailed feedback.
Please let me try to give you detailed responses to your interrogations.

Could you please elaborate a bit more on this point?
The MIDI key (scales) detection is following the principles introduced in Scaler 1, it gives you a list of results matching your input, do you have a specific case where it do not work as expected according to your input ?

example: with a “I iii V IV” progression only on white keys, C major or G mixolydian etc. seems good from a theoretical point of view:

you can first change the global duration of all the chords:

then when dragged into the C section : the builder you can open the Edit Matrix view and from there if you multi-select chords you can then change the duration of more than one chord at a time

I am not sure I understand this point, could you give more details ?

You can right-click on the play button from the pattern builder to turn ON/OFF the daw sync

you can click on the scale tonic when it has a # or a b in it’s name to toggle the namings see this example :

as you can see in the scale the second chord is a A min but it become named a B double flat (Bbb) to suit the name switch.

do you have some example ? have you tried Scaler internal quantised options ?

I don’t get what is going on here “everything is off” ?

Scaler let you play the currently selected pattern by default but you can multi-select pattern tabs to tell the playback daw sync which tabs you want to be played in order from left to right

here it will be playing “Pattern 1” until last chord and then it will witch automatically to play first chord of “Patten 2”

to make it loop, you can try enable the looping in your host, this way scaler will restart at first chord of either current pattern if only one pattern selected or first chord of first pattern of your multi-selected patterns.

please continue, your feedback is appreciated, before could you have a look at the manual or wait for video tutorials since most of the “bugs” you have reported are more workflow misunderstandings.

Thank you, tell me if that helps,