Can not install Scaler2

I bought it from Pluginboutique and downloaded “Scaler-2.0.5.exe”.
Then run the setup file with administrative rights and select the folder where you want to install the VST file.
Then, when I start the installation, I get a “CreateFile failed; code2” error and the installation is aborted.
How can I solve this problem?

I’m using Windows 10.
The language environment is Japanese.
The CPU is an i9 9900k.
It has 64GB of memory.
The system drive has 360GB of free space.
There is at least 2TB of free space on the HDD to be installed.

I also tried installing it with Version 2.0.6 and got the same error.

It may be a location permission issue. Sometimes certain folders are locked, and you have to unlock them by enabling perssions to WRITE to that folder.

Try to install again, and pay attention to install location. Then manually check to see if the location is read-only. If so, disable read-only and make it “writeable”. Should fix your issue.

1 Like

Thanks for writing in, AntiPyr8!
I have tried the following.
1-1. I removed all read-only folders from my installation, including the subfolders.
1-2. “CreateFile failed; code2” error appeared.
2-1. I removed all read-only folders from the default installation, including the subfolders.
2-2. “CreateFile failed; code2” error appeared.
3-1. The read-only function of the “Documents folder” (C:\Users[Username]\Documents) was removed from all folders including subfolders.
3-2. “CreateFile failed; code2” error appeared.
4-1. Removed all read-only “user folders” (C:\User), including subfolders.
4-2. “CreateFile failed; code2” error appeared.

I’m pretty sure I’m running the setup work with administrative privileges.
I’m trying to figure out if there’s any other way to do it.

Just checking, have you tried installing everything in system defaults as opposed to custom folders?

davide, thanks for writing!
I’ve tried the default install.
The default meaning in this case is “No custom settings at all. Only the Install button is pressed”.
However, I can’t install it.

I’m not a windows user so I am not best to advise here I will let one of the other guys chip in but certainly seems like a permission / security issue. Lates version of windows? Anti Virus software? Something casing problems? Any one else? @luapmartin

Thank you so much!
I only use “Windows Defender” as my antivirus software.
I’m using Scaler 1, which I can install and use normally.

Here’s some information about Windows.
Windows Edition: Windows 10 Pro
Windows10 Version: 1909

Hi @Nie,
my first suggestion would be to try update your windows to the latest version, since it has shown to be problematic for another user :

Cheers,
Paul

Hi @luapmartin Thanks for writing!
Version 2004 of the Windows update has not been delivered to me yet, so I was unable to update.
I don’t think many Windows users have received version 2004 yet.
Do I have to wait until Version 2004 is available?

From the thread you referred me to, I see that installing KB4549951 will work. It seems to work.
So I checked my update status and found that “KB4549951” was installed and It wasn’t there.
So I installed “KB4549951” and restarted my PC.
I then ran the setup file and still got the same error.
My guess is that Scaler2 setup and “KB4549951” are probably not related. It seems.

I’ve solved the problem!
Here’s how to solve the problem

  1. OneDrive may be automatically installed in Windows Update.

  2. turn off OneDrive’s sync settings and break the automatic link to your account. Here’s how to do it.
    https://support.office.com/en-us/article/turn-off-disable-or-uninstall-onedrive-f32a17ce-3336-40fe-9c38-6efb09f944b0
    The reason for this step is that the OneDrive synchronization settings will change the write permissions of the document folder when it is set to On.

  3. Then turn off the “Ransomware Protection Settings” in WindowsDefender.

  4. you now have write permissions for the documents folder back! Scaler2 installed without incident!

2 Likes

Woah @Nie ! Great troubleshooting

I am sure it will help others, thanks a lot for sharing

1 Like