Can't upgrade Scaler from 2.8 to 2.9 in FL Studio

I am pulling my hair out trying to upgrade Scaler to 2.9 in FL Studio,
I appreciate this is most likely not a bug but I need some help please.

This is what I have done…

  • Downloaded Scaler 2.9 (as a free upgrade) from PluginBoutique. Windows 10 (6439_Scaler-2.9.0.exe)
  • I have gone into FL Studio and have deleted the existing Scaler 2 plugin from Generator VST, VST3 and from any special category ‘Special Synths’, ‘Instrument’ etc.
  • I then exit FL Studio
  • I have deleted both the Scaler2.dll and Scaler2.vst3 files from the appropriately mapped VST folders on my computer.
  • I run 6439_Scaler-2.9.0.exe until successfully completed.
  • I go back into FL Studio, manage plugins to pick up Scaler 2, favourite it to appear in Instrument category.
  • I add a new Scale 2 as an instrument and it just shows the old Scaler 2.8 application!

Your help on this would be greatly appreciated.
Many thanks

HI @CreativeGuy

Welcome to the forum. Could you clarify which OS version you are running, please? It may help identify the issue, and a user on the same OS may be able to help resolve your issue.

Many thanks

Hi ed66,
It is Windows 10 as stated (64bit)
Hope that helps :slight_smile:

[SOLVED] If anyone else has this problem just uninstall the existing Scaler 2 using Windows 10 ‘Add or Remove Program’. Restart your PC. Run 6439_Scaler-2.9.0.exe until successfully completed. Go back into FL Studio, use Manage Plugins to find the new Scaler 2 (v2.9) plugin. You can then use Scaler 2.9 fine!