Don't disable playback when changing patterns

I noticed that when inside the Scaler interface and using playback in loop mode, the playback stops when selecting a different pattern. This occurs when selecting a pattern button (Pattern 2) with the mouse as well as when using a Navigate To Pattern Command Mapping.

I would be great to be able to move between patterns and keep playback in time like you can do when changing performance settings.


1 Like

Hi @TMacD

Just tried this in Reaper (on Windows 10)and found that it could be an issue, but if I set looping on and bind the patterns, then the playback does not stop when I use the binded key switches to switch between patterns.

Also it does not appear to be an issue if I use midi output from another plugin, such as Stochas, to send key switching notes into Scaler.

I wonder if it is a (for me relatively minor) bug that playback stops if you simply use the mouse to choose your pattern.

Thanks @ed66.

Tried a couple key switch experiments and found that it does seem specifically related to the two use cases I mentioned (mouse click to select a pattern and Navigate to Command Mapping)
The green Scaler key switches in the UI work perfectly with both a mouse click and via a midi controller trigger.

As you thought, it must just be a little UI bug so this gives me a work around. Thanks a ton.

Hi @TMacD

Well spotted. I agree that whilst it may be a small use case I think it should maintain playback like you stated. It is not necessarily a bug but I believe it should be a feature. I will lodge this request with the development team. Thanks for your input!