[Fixed] Removing multi-selection of chords not working correctly

Removing a muli-selection of chords does not produce the expected result. Given the chords I selected below, I would expect to see the expected results pictured below. Instead, I get the actual results pictured below.

Reproduction steps:

  1. In pattern editor
  2. In pad view
  3. Select some chords as in this picture
  4. Right click, and remove those chords

Expected results

Actual results

My system:

  • Ableton 10
  • Win 10
  • Latest Scaler

Just tried to duplicate this and mine behaves as expected.
OS 10.13.6
Ableton Live 10
Scaler2 2.0.9

Thanks for trying to repro this and the other one. Maybe it’s only an issue on Windows?

Just tried this again with a different chord set and it behaved just like yours i.e. instead of removing the 13 selected chords, it removed only 8.

So you’ve confirmed the bug. Thanks!

That was in all patterns open view. So trying to remove chords in multi patterns seems problematic.

Hi @jbone1313

Thanks for reporting your issue with the detailed steps to reproduce, we will have a look and fix this soon.


This seems fixed in 2.1. Lighting fast! Thanks!