I still have timing issue with new 1.2.1 update (Logic Pro X user)

There’s still a major issue with the timing when using Scaler 1.2.1 with Logic Pro 10.4.1. I have a set of chords in scaler triggered by one-note keys & I when I start to record a drum track scaler falls out of timing. I have to stop the session, diable scaler & the reenable for it to sync back correctly. I hope this issue gets attention & fixed in the next update… :wink:

Hi @theblaqmann

This is interesting, would you mind giving us more info about your issue so we can start investigating ?

Is it only happening while recording on another track ?
What do you use to record drums (audio input, virtual instrument,…) ?
What kind of timing are we talking about ? Is it milliseconds or completely out of sync ?
Is it always fixed simply by stopping the recording then disabling/enabling Scaler ?


I Haven’t been able to replicate this issue at all and I have exactly the same setup. I’ve tried recording on other channels via midi via keyboard input and nothing. I suspect this is a timing sample rate issue to do with clock somehow. Please respond to Ed’s questions and let’s see if we can help you figure it out.

I use NI Battery 4 & EXS24 to record drums & yes it only occurs when adding more tracks or more drum parts.
If I start off with a simple kickdrum 1st to lay down a chords progression it seems ok. After I start
building more of the drum track, that’s when Scaler starts to drift. I then have to disable & then
re-enable Scaler to get back the timing. It’s falls behind only milliseconds but it’s noticeable. My workaround is to add AudioCR midi freeze, capture the chord progression sequence & then disable Scaler altogether.

Thanks for the update. We will run some tests to see what’s going on.