In Cakewalk - can not get Scaler 2 to play a Kontakt instrument

I have one track for Scaler 2 in Cakewalk with MIDI in from a 49 key keyboard on channel 2. I can select a sound and play the piano keys and hear them. I can click on a chord and it plays with the selected sound.
I can do a midi capture and send the midi to a track with a softsynth and then play that track.
On one of the developer’s YouTube videos he was able to click on the chord in SCALER 2 and have it played by a Kontakt (Acoustic Guitar) instrument directly without the MIDI capture and drag process.
I do not see any way to send the active(?) MIDI out from scaler to another instrument. How did he do that?

You need to make sure the chord pads on Scaler are set to Bind. On the right side of each area where there are chord pads is a square. Click on that to activate it. Then your keyboard will trigger the pads starting with C2 on the keyboard and continue upward depending on how many pads are in that section.
Also you have to have the instrument routed to your VST Instrument. Here is a video

2 Likes

You may have a problem with Cakewalk (I assume the Bandlab version) because of VST location; it always was in conflict with Stenberg placement (and others) . NI also can cause issues. It’s all down to where you have located the VST(2) files.

However, I just tried it out (I don’t use Cakewalk except for a few things) and I first had to add the Native Instruments location to the Plugin Manager and rescan.

You will see that it found Kontact in the location specified.

However - I had not tried this before - when I called up theVST2 plugins to drop Kontact on to a track, it wasn’t there.

plgs b,

but all my other NI synths were.

I’d have to look into this in more detail, but it may be that Cakewalk doesn’t handle ‘containers’ like Kontact, which themselves load the actual VST.

Ableton Live doesn’t have a problem …

Maybe @Trankonia, (a Cakewalk veteran) if he looks in sometime, might comment whether he uses Kontact and if he’s had an issue.

Yes, I do use the ultimate NI library. I have been out a bit due to an injury but should be able to get back in it in a few days. I do not recall having issues with using NI with cakewalk and I have numerous VST folders. Are you using the NI Control or the Main NI launch program? Sorry…not at the computer to verify names. Please describe the process steps you are doing to bind scaler to the cakewalk track that has the NI instance attached. Kontakt should be able to bind to a track and the have scaler point to that track. At least that’s how I remember setting it up. I should be able to take a look next week.

Hi @yorkeman, silly question, but did you rescan the vst plugins?

The Cakewalk forum is still going so you may find the answer there.

Only Kontakt and NI control are vsts. The instruments are not as they are samples.

It appears as though the screen shot launches Kontakt player which will not have library entries. You need full version for that and certain sample titles. It seems that you are not navigating to where the actual sample files are to load them. Have you been able to load and play samples in cakewalk without scaler?….sorry just saw that Ableton live works for you. I know for a fact that Kontakt does load in cakewalk as I use it all the time. If it does not work now perhaps I do not have the same release of Cakewalk as you. This is certainly not a scaler issue. Let me test next week. Please post if you find a way to resolve. Have you tried to create a custom instrument menu? Perhaps that may make the container appear. By the way the container does not load vst files.

Hi @ed66 and @Trankonia

I was actually only trying to see what @wstewl 's problem was … I don’t use Cakewalk except for the occasional staff print and a couple of other things.

Yes, ed66, I did do the refresh and you can see it picked up all the non-Kontact NI VST’s which it found when I declared the location and scanned

I think the issue lies in trankonia’s comment, and that my version of Cakewalk does not recognise the Kontact player container DLL, although it looads in Live ok.

A quick scan of Google shows multiple report on this issue quite recently (there was a change to Bandlab i May 2020). I didn’t both to tack tis down further as I don’t use Cakewalk like that.

However, I could load Komplete Kontrol and pick up the Kontact instruments that way, so @wstewl could do it that way. He’s a shot of Arkhis running in Komplete Kontrol on a Cakewalk track.

Thanks for the input, all

Hi @yorkeman @Trankonia

Like you I only iused Cakewalk occassinally, and have recently uninstalled it, as I have always found the interface a bit difficult to navigate, even after customising it.

I must apologise with my query about rescanning the vstis. I wasn’t trying to teach egg sucking when I asked about it. I regularly forgot to do this when I was using Cakewalk (I had switched off theoptin to automatically do scan on loading to speed up the loading of Cakewalk).

Absolutely no need to do so at all - thanks for the reminder ! I forget this regularly in Live :frowning:

I used this expression recently, and although I did a literal translation to Italian it still didn’t make much sense to @ClaudioPorcellana … I think he is sometimes amused at my English expressions.

1 Like

it seemed to me yours was a bit different… :grin:
so now I have two more
thank you to both :rofl:

Using version 2022.62 (build 039, 64Bit) I had no issue adding Kontakt to Cakewalk. As I mentioned, I also add the VSTs to a custom menu. I would do a full delete and re-scan and then look at the path that Kontakt shows in the list.

By the way, I am using the 64 bit VST dll

Of course, once you are able to get NI Kontakt into Bandlab then you need to have scaler be the input into the instance of Kontakt. (if I remember correctly)

Hope this helps.

1 Like

Thank you for the helpful video. Well done! It solved my problem.