In Chordal mode, I can't turn chords off?

Maybe this is by design, and I don’t fully understand the functioning of the “Chordal” mode. But I tried to turn off the chords and just hear the Melody. But these options are grayed out when in this particular performance mode…

I believe that affects the melody expressions. IIRC with chord and melody on you hear a solid chord at the start followed by the melody. With melody only you just get the melody without the chord hit. With chordal since there is no melody it makes sense it’s grayed out.
At least that’s the way I see it behaving.

Correct. Wherever Scaler adds a chord the option (such as a Phrase) the option appears to play melody only. Remember a performance is how a chord may be played by a musician/pianist ( usually just the notes of the chord not necessarily played together) and a phrase is a chord interpreted melodically ( usually a chord + a melody )