Is this a bug in the Scaler Control 2 updates?

Okay, I’ve realized that the problem lies with the voice grouping global application. I didn’t notice it was a real problem for me until the latest update. None of the editing functions work correctly when the voice grouping is turned on. There doesn’t seem to be a way to turn it off without disabling one of my favorite ways of finding new chords etc. At this point, Scaler has become a major source of frustration because it’s difficult composing without being able to freely change the chords individually ON EACH TRACK.

I have read others having the same problem but not sharing the solutions. I wouldn’t bother writing this but Scaler has become an important tool in my compositions.

Are there easy workarounds to this problem? Thanks for listening! :upside_down_face:

Pic 1 shows F major chord voicing OCTAVE 3
Pic 2 shows F major chord voicing OCTAVE 4
Pic 3 shows F major chord voicing OCTAVE 5

If you notice the CHORD PATTERN REMAINS UNCHANGED even though I have changed the octave twice.
The same goes for chord inversions. For some reason the chord voicings and inversions don’t work. When I turn off voice grouping everything works like it should.

Scaler 2.6 voice grouping
Scaler 2.6 voice grouping 2
Scaler 2.6 voice grouping 3

Hard to tell what you are doing there without seeing it @AJB
Do you have any voice grouping turned on? Maybe post a video so users can help.

Thanks for the reply. Yes, the voice grouping is turned on, but the chord voicings do not work at all.


Peering at the videos I see you have Dynamic Voice Grouping enabled.

To disable this simply click on the blue Voice Grouping

Or you can disable it in the Settings panel

although you may have to scroll down to find it

Hope this helps

Thank you for the reply. I was asking the wrong question because of the small banner that pops up letting me know that global voice grouping is on. I actually want to keep the dynamic voice grouping, but if you look at my gifs the octave chord voicings do not work. The inversions do not work either. If I turn off the voice grouping function everything works fine. At this point, I think it’s a major bug in the Scaler Control 2 updates.

This is the way Dynamics react so I don’t think it is a bug per se. The idea is to minimize the distance between notes from one chord to the next. A sort of voice leading to avoid big jumps in intervals. However, as you’ve discovered it seems to render certain intervals like octaves and inversions non viable. It would be nice to keep inversions. and octaves.
Other then writing the notes in the order you want and avoid the Dynamics button I don’t know another way.
Dynamics overides settings of Chord Voicings on the Edit page and that is Global.

1 Like

What you are saying is technically correct, but this is the way I have been using Scaler until recently. I would recommend trying Scaler Control 2 and see if you can replicate what I am talking about. The entire voice grouping section does absolutely nothing no matter what change I make. I picked C major by itself with no other chords and none of the voice groupings work as they should. I get sound of course, but at least one note should change with the dozens of attempts I made.

So are you saying that if you change say to Dynamics +1 it does not shift up an octave?

Scaler Control 2 is designed for Logic as a MIDI effect insert so I haven’t seen what you are seeing. I’ve stopped using Logic a while back and have since gone on to Cubase. I still have Logic but I’m running Catalina. Are you running on an M1 Mac?

Yes, that is what I’m saying.

I use it mainly as a controller for MIDI instruments.

I have an M1 Mac mini running on updated Monterey and updated Logic Pro.

Have you tried running it under Rosetta? This has solved problems people are experiencing with Scaler in Logic under Monterey. Logic Devs have broken 3rd party MIDI FX and kind of need to get that sorted on their end.

Yes absolutely! Rosetta only! This is the way. :grin: Interesting to hear about the broken MIDI FX devs.

Just out of curiosity, how do you use Scaler? I need to figure out a new way to compose with MIDI as a workaround until this is fixed at some point. Any ideas other than using Scaler as a Control?

Thank you for the help either way!

Hi @Ed1, can you let me know if this is a bug or not? I know you work hard, but I would appreciate a response from someone in your department so that I can move on.

I think you may have the wrong Ed. I am not a member of the dev team, I am simply a user like yourself. As a member of this community I try to help other users when they have questions.

My apologies! I thought you were Devs since you are so active and know so much.

I now realize there’s an @Ed1.


this is not a bug, the voice grouping will group the notes around the tonal center of the selected scale.
You can’t change where the voices are played because we are forcing them to be grouped around a specific area.

This is the reason some controls like octave and inversion have no effect when the grouping is ON.

However, it seems there is something odd in what you experience because on my end, I do hear a difference when using different profiles of voice grouping. When disabling the voice grouping the octave and inversion controls work as expected.

What is the exact setup of your project? Maybe test a single track with ScalerControl controlling a default Logic instrument. You should be able to hear the difference between different voice grouping.

You can also check at the bottom of the EDIT page where you can override the Voice Grouping profile for each chord. Maybe something is wrong and the chord is forced with a specific grouping and ignore the global one.

Hi @Ed1

Thank you for the reply. I am not trying to force or change the grouping in any way. I’m just trying to use whatever it gives me for inspiration. Something should change with a minimum of 24 parameters to choose from no matter what the tonal center or selected scale is. Well, nothing changes unless I turn off voice grouping and then things sort of work. It’s real buggy!

When voice grouping is turned on, starting with dynamic and clicking down the list, they don’t react when played. The chord voicing parameters don’t work ( octave, inversion, semitone actually works but I don’t need it). Changing most of the parameters does nothing. When I change a parameter with the mouse, the sound changes automatically. But, when I play the keyboard to the new parameter I just clicked only the original parameter sound plays, and not the change that I had made.

I have tried all of my instruments including Apple and I get the same results. I’ve tried to uninstall and reinstall Scaler. Of course, I’m not very tech savvy so I probably missed folders when uninstalling.

By the way, this is a new problem for me within the last few months. My setup is extremely simple because I’ve been testing a single track to find the problem. I use Scaler as the controller > MIDI instrument > effects(compressor etc).

The edit page voice grouping profile doesn’t work (yet) for my writing style. I’m working my way down the edit page, but the beginning has to work first.


Can you give me step by step instructions how to completely uninstall all of Scaler 1 and 2 from my Mac? Please don’t leave anything out.

I will try to reinstall 2.4 and see if that helps.

Thank you!


Open the finder on your mac and navigate to these folders to delete everything related to Scaler on your system:

Data, Settings, and License Location

Macintosh HD⁩ / ⁨Users⁩ / [ username ] / ⁨Library⁩ / ⁨Application Support⁩ / ⁨Plugin Boutique⁩

Sounds, Sets, and Documentation Location

Macintosh HD⁩ / ⁨Users⁩ / ⁨Shared⁩ / ⁨Plugin Boutique⁩ /

Plugins Locations

  • delete all files starting with Scaler like Scaler.vst3


Macintosh HD⁩ / ⁨Library⁩ / ⁨Audio⁩ / ⁨Plug-Ins⁩ / Components


Macintosh HD⁩ / ⁨Library⁩ / ⁨Audio⁩ / ⁨Plug-Ins⁩ / VST


Macintosh HD⁩ / ⁨Library⁩ / ⁨Audio⁩ / ⁨Plug-Ins⁩ / VST3


Macintosh HD/Library/Application Support/Avid/Audio/Plug-Ins

Okay, I’ve officially tried everything. My final assessment is that voice grouping is definitely broken for me. Maybe it’s not officially a bug, but it doesn’t work. It used to work just fine because it was part of my workflow for a few years. Who knows, maybe it’s just M1 problems. NEXT!

Did Scaler work for you using any past versions? It sounds like it must have worked at one time if you had a workflow that went away. What changed? Were you always on an M1 or is that recent?