License file not working on Dell tower PC

I worked for 2 years on my old Laptop with Scaler 2 purchased from pluginboutique.
I downloaded Scaler 2 and license files again on my new Dell Pc
Scaler 2 shows up in Ableton but when I want to get the license to activate it does not show up (neither on Desktop nor in a folder I created) - I can not click/open it to activate Scaler.
Where am I wrong?

Hi @Nesch Welcome to the forum. Have you clicked on the ‘S’ logo top left of Scaler and clicked ‘About/Help’ and then registrations? Or are you saying you can get there but when you load/open the licence nothing happens? If it’s the latter please send me DM me with proof of purchase I can have a new licence generated for you to see if that helps.

1 Like

Hi Davide,
thank you for your reply. Yes, I tried your described way, a couple of times. I can not open the license file.
Please send a new license.
Proof of purchase attached - I rated it 5 stars on plugin boutique.
thank you for your help
PS how do i DM here?

Hi @Nesch I have sent you a message, you should see a notification on the top right next to your profile pic. Please respond to me there.