Logic Pro X quit unexpectedly while using the Scaler Plug-In

Hi folks - new to Scaler - have used it in a couple of projects to help with chord work, but I can NEVER re-open the projects which is now a nightmare. Have reset and rescanned plug-ins still no joy. Recording session this week with artist but cannot open project where I have recently used a track for Scaler. Any help much appreciated.
IMac Pro 2017 version 10.14.2 . Logic pro 10.14.6
bit of info below from log report:

PlugIn Path: /Library/Audio/Plug-Ins/Components/Scaler.component/Contents/MacOS/Scaler
PlugIn Identifier: com.pluginboutique.Scaler
PlugIn Version: 1.8 (1.8)

Date/Time: 2019-11-17 10:40:13.424 +0000
OS Version: Mac OS X 10.14.2 (18C54)

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000018

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [3368]

VM Regions Near 0x18:
__TEXT 00000001006b1000-000000010237f000 [ 28.8M] r-x/rwx SM=COW /Applications/Logic Pro X.app/Contents/MacOS/Logic Pro X

Application Specific Information:
MALondonIII | e84d8ecce95d250e32c0f73d4c79d2b685e8718a80997af9a2b0f6c679216e01 | 28ef55f40e5dbf5cba062f4ca06868a3dc8a114d | 2019-07-04_15:24:24

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 com.pluginboutique.Scaler 0x00000001306945cb 0x130644000 + 329163
1 com.pluginboutique.Scaler 0x000000013069181c 0x130644000 + 317468
2 com.pluginboutique.Scaler 0x000000013068ff0d 0x130644000 + 311053
3 com.pluginboutique.Scaler 0x0000000130667095 0x130644000 + 143509
4 com.pluginboutique.Scaler 0x00000001307d050c 0x130644000 + 1623308
5 com.pluginboutique.Scaler 0x0000000130766014 0x130644000 + 1187860
6 com.pluginboutique.Scaler 0x0000000130651192 0x130644000 + 53650
7 com.pluginboutique.Scaler 0x0000000130657374 0x130644000 + 78708
8 com.apple.music.apps.MAAudioEngine 0x00000001050c1b89 CMDAudioUnit::SendClassInfoToAU(void const*, bool) + 281
9 com.apple.music.apps.MAAudioEngine 0x00000001050b7c8e CMDAudioUnit::SetSettings(void const*, long, long, void*) + 270

Thanks for reporting your issue.

So you can find Scaler in Logic Pro, add it to a track use it normally then save your project. But when you try to open it back it crashes on opening?

This is quite unusual. We will have a look.
It would help if you could share one of the project you can’t open so we can have a look at what is going on.


Hi Edouard,

Thanks for getting back - much appreciated. My first question before I try to find a project I can send happily, is how do I do a complete uninstall of Scaler? I’ve tried removing the library folder and cache folders, but it still shows in Logic Pro plugin manager and each time I try to open the project it adds the folder back into library! I also noticed it was asking me for my license when it did this in a new project so I wonder whether there is a second occurrence of Scaler somewhere on the system?

I have now managed to open a previous back up of the project so immediate panic is over. Would like to try a complete reinstall and clean uninstall though.

Thanks so much,


To make sure everything is clean:

  • Remove VST/AU/AAX plugin files:

    • /Users/[Username]/Library/Audio/Plug-Ins/Components
    • /Library/Audio/Plug-Ins/Components
  • Remove resources folder:

    • /Users/Shared/Plugin Boutique/Scaler
  • Remove settings folder:

    • /Users/[Username]/Library/Application Support/Plugin Boutique/Scaler

After this Scaler should not be visible in Logic Pro.