Midi capture contains zero length notes

I’m using Studio One 6 with Scaler 2.8.

I recorded a sequence of a chord progression, bound it to section C, turned off Sync to DAW.

I selected a pluck sound, turned on Perform > Rhythms > Common 10 and set Perform Mode to Follow.

It starts on an offbeat and has a nice bounce to it.

I turned on Midi Capture and was surprised that the performance had lost it’s groove.

I realized that the Midi Capture started on the beat and lost the bounce.

I noticed that the Midi editor had notes that were zero length. These are the notes that give the groove the bounce.

I tried routing the Midi events directly to a virtual instrument (Synthmaster 2 with pluck preset) and found that although it played on the offbeat, the bounce was missing. I tried another virtual instrument (Analog Lab 5 with pluck preset) and found that it had the bounce of the groove. My guess is that Analog Lab 5 was triggering a sound for the zero length notes but Synthmaster 2 was not.

I edited the zero length notes in the captured Midi and made them 1/32 notes and now it sounds just right whichever Virtual Instrument pluck sound I use.

I can’t find a setting in Scaler to control this. I’ve used Scaler for a while but hadn’t noticed this before although I had noticed the zero length notes in the captured Midi. It might be because I use Analog Lab a lot which seems to not show this problem.

Am I missing something or is this a known issue? I didn’t find a topic about it on the forum, but maybe I missed it.

Here’s a screenshots (as a new user I can only upload one):

Hi @gwhn1604 welcome to the forum and thanks for sharing what you have found.

I have had a look at this and those zero length notes shouldn’t be there. So I think you might be right in that some instruments may be triggering them while others might not. That would explain the inconsistency in the groove.

I will forward this on to the rest of the team and we will look at addressing this.


These zero length notes have almost always been a part of Scaler. I think it is better now but they are still there. Since I use Cubase there is a Logical Editor script that easily removes them and I just use that once the Scaler performance is finalized to MIDI. They tend to be easy to spot in Cubase so running the Logical Editor script becomes part of the cleanup.