Midi Capture Scaler 2

Hello I recently purchased the scaler 2 upgrade from plugin boutique … when creating a chord progression I noticed that the capture midi feature is not working correctly. If I use the bind midi feature to create a progression and then capture that midi when I drag it into my daw (Ableton) it plays chords that were not apart of my chord progression. Also when I hit play in my daw to play the midi clip that dragged in I notice on Scaler interface there are only 2 of the binded chords being activated … if there is anyway you could help me with this or I can be given a different version or refund it would be greatly appreciated

Do you have any recorded trigger chords in your DAW by any chance? This isn’t normal behaviour. You can submit a video of what you are doing and we will take a look and of course you can always get a refund from where you purchased it from.

Thanks for the response but no there aren’t any recorded trigger chords … I’ve tried this on a new Ableton Project as well to make sure I will try to get a video soon … I’ve also noticed that when I try to pull up Scaler 2 in my daw there are 6 different versions that pop up is this common? and could this have something to do with the

No that is not right. I am guessing you were one of the beta testers or you had a beta version installed. That could well be the issue as it freaks Scaler out (did for me). I would delete everything .dll VST Au and reinstall scaler 2.0.4 and reboot,

1 Like

ok thanks ill try that now

Hey I tried again and im still getting the same problem … I deleted the plugin and reinstalled it but im still seeing 6 different versions when I search it in Ableton. I purchased the upgrade from scaler 1 and im not sure if that has anything to do with it but I just finished the video and tried to upload it I got a message saying that I was not authorized to upload that kind of file is there another way I can send this type of file ?

or any email that I can send the video of me showing whats going on ?

It is normal, you have installed all the versions from the installer and Ableton Live is configured to detect all plugin formats so you are seeing:

Scaler 1 - In AU, VST2, VST3
Scaler 2 - In AU, VST2, VST3
ScalerAudio 2 - In AU, VST2, VST3

Regarding the video of your issue, you can send it to me: ed@tonicbits.com

1 Like

ok sending it now thanks again

hello I sent a video displaying the problem to the email above from kingmillz3@gmail.com please feel free to respond here or to the email connected to this account or kingmillz3@gmail.com thanks !

Hey @Milly93

I see what’s going on, the MIDI Capture works well, but when you play it from the track Scaler is still active with the BIND on Section B. So the MIDI that comes in re-trigger the chords as well as play the captured notes.

This is why you don’t hear what you expect. It is not a bug, but it can be confusing at times.

You can either disable the BIND in Section B after dragging, or dropping on a different midi track would work as well.

Hope that makes sense,

Hi, I recently bought Scaler 2 from Plugin Boutique and I’m having problems capturing MIDI. When I play the chord progression using the commands, it gives me the right sound but after recording the MIDI, it plays a different chord when transferred to the piano roll. Sometimes, it doesn’t record the MIDI at all. I don’t know if it has something to do with my DAW. I’m using FL Studio. I sent the video to this email ed@tonicbits.com


thanks for sending the video through,

The behavior is normal, you are dragging notes onto Scaler which still has the BIND and the performance active.

Any note played on Scaler’s track will trigger the bound chords and the performance.
Try to drag the clip onto a different track and this will solve your issue.


Hi I am having a different issue with midi capture. So I created my chords down in binded C section with the main scaler 2 plug in. I want to midi capture the actual chords, but when I hit midi capture and let it record the chords of C section, I hit stop then drag and it just drags out an extremely large empty track on Ableton.

I have the binded chords recorded on the scaler track already and just want to recapture with the actual chords during DAW playback

1 Like

Hi @zeez,

thanks for reporting we will have a look.

Is it happening every time you try to MIDI-Capture or just in this specific case where you try to capture the playback with notes already on the track ?

I had the same issue with Scaler 2. The midi file that generated is a long empty midi file with the actual chords in the end of it.

I seemed to have it fixed about 70% of the time. What got it to work properly is that you need to stop midi capture before the DAW loops back around to the start.

Did you sort the problem out? I had the same problem after capturing the midi and pressing Stop on the transport bar in Ableton before pressing Stop in Scaler. If I pressed Stop in Scaler after finishing capturing the midi, and then pressed Stop on the DAW things turned out how you’d expect.

Uninstal scaler,go to vstplugin or steinberg folder (which do u use?) delete plugin boutique or go inside choose all scaler.dll,then go to c/user/appdata/roaming/pluginboutique,choose all folders about scaler then delete them…

Now u will have a newborn baby.