MIDI detection broken?

Hi All, using Bitwig 3.3.6, this morning I’ve realised that MIDI detection is doing nothing. I used the feature before, so I guess I am using it correctly. I press the “rec” button, then start playing into the track with Scaler, I can hear the Arturia Piano V2 that comes after Scaler, but Scaler is not showing anything. Any ideas? Thanks,


Hey @giacecco
That does sound odd, I tried to reproduce and could not. I never see Scaler act up so I’m betting it is a
pretty simple issue. For more context and to help others help you:

A couple basics (sorry, had to ask)

  • Is Scaler active or in focus (are you sure you are not hearing your VST independent of Scaller)
  • Your SRC is set to MIDI
  • The “rec” button (inside Scaler) turns to a red square with a white circle, and it does not revert to a red circle in a dark square. It stays a red square while you are playing?
  • You see the text: WAITING FOR IMPUT after you click the record button?


If all that is good, a couple other questions might help others smarter than I:

  • Any chance you you are running ScalerAudio2 and not straight Scaler2 (not sure how/why this might make a difference, but since you cant tell the difference by looking at the UI, it has happened to me)
  • I don’t know Bitwig, but did you do anything out of the ordinary with routing/instantiation of Scaler this time?
  • Have you tried a Scaler internal instrument and not your Arturia VST?
  • You are not binding your keyboard to one of the chord areas (this will disable the record button)?
  • When you play, do you see the keys on the Scaler keyboard change to blue?
  • Have you tried to click a note on the Scaler keyboard?
  • Are you clicking a chord w/in a pattern (disabling record)

Hope something here helps. If not, someone will figure it out.


1 Like

Hi @giacecco,

I also tried to repro your scenario, since I also have Scaler 2.3.1 on Bitwig Studio 3.3.6, and Arturia V Collection.

Scaler does “detect” MIDI notes from the another track, but I have to use the “Note Receiver” device. Just linking the channels (like the red x-ed out part) does not work for me either. But I usually don’t use that connection method. I always use note receivers.

The receiving Scaler instance records the notes from the other track, once I have Scaler armed in (detect) record mode (per @TMacD 's guidance). And it passes it on properly in the same track to the Arturia Piano V2.

Here’s my test project in Bitwig, if you want to take a look at the details…