MIDI detection suddenly not working. Ableton 11.1.1

Hey, I didn’t see an e-mail address to contact the guys that make this plugin so, I’m posting this here/wondering if anyone else is having this issue:

Suddenly the MIDI detect function isn’t working. The keys are playing at the top of the plugin but it’s not coming up with the scale suggestions in the lower box.

As far as I’m aware I’ve changed nothing.

Tried the latest version, same deal. Tried flicking through all 16 MIDI channels, nothing.

Any ideas?



Unfortunately you’re not really telling us anything.
What computer system and OS are you using? How are you trying to detect the MIDI? Drag and drop MIDI file onto Scaler? Some other way? You say nothing has changed but clearly something has. Have you upgraded anything?
Thanks for any info.

What I’m saying is when I drop Scaler into a midi track with midi notes on the track, the keyboard at the top of the plugin is playing notes but when I hit the record button to bring up the list of keys/scales it’s not generating a list of potential scales/keys.

Nothing about my set up has changed/there aren’t any issues regarding OS etc. I’m on Mojave so I’m not updating on OS. It’s always worked perfectly but suddenly even though I’ve changed nothing it no longer generates the list.

I did recently upgrade to the latest version of Ableton tho. That’s the only thing I can think of.


I’ve never dropped Scaler on a MIDI track. I always drop MIDI on a Scaler track. Does the MIDI track consist of chords? Because Scaler won’t detect single note lines well.

Well, the fact that you’ve never done something is irrelevant. I just use it for scale detection. Write something, make a new midi track, put a copy of the midi I just wrote onto it and run Scaler to see which scales and keys I can use to work on the track.

Just forget it passive aggressive forum guy and go about your business.

Hello, Phantom Him.
Welcome to this forum which is by no means passive, and even less aggressive. Here we all raise our doubts or problems and try to help each other. When we can’t get it between ourselves, Davide or Ed1 show up and find the solution.
I am well aware that Jamieh is an active member on this forum always trying to help those of us who ask.
Keep in mind that we live in different countries and we connect at different times.
Regarding your problem, although the normal thing is to have a midi track with Scaler and drag the midi progression to the Scaler track, I have also done it as you do and it works just the same. With midi files that contain chords and individual notes it works equally well and I have used it like you, to detect the possible scales that said notes would admit.
Just remember to hit the record button on A.
Scaler will detect the notes and/or chords and will suggest several scales in order according to the number of notes that coincide in them. But it is important that after clicking on the record button of A, you give it play in your DAW
I do it regularly in Ableton 10 and it works

I made a simple statement and asked a question. I don’t know what your problem is. I was trying to help and you lash out. You are now on my ignore list.
Goods luck.

1 Like

Hi Phantom

I have just tried this using a midi clip playing single notes (it is a bass line) and Scaler detected the notes and displayed them in Section A.

Below this Scaler highlighted a suggested a scale that would be appropriate for harmonising the midi clip. It also displayed other scales that could be used as an alternative to the suggested scale.

By clicking on the scale the scale chords were displayed in sectin B. I could then select chords to include in the pattern

I repeated this with midi clip of chords and again Scaler identifes a suggested scale together with a number of alternatives.

Is that what you were trying to achieve?

I am using Scaler 2.5 in Ableton Live 11.1.1

Hey Ed. Thanks for the reply.

It’s weird, I actually tried using it the way I always do on another track and it works perfectly. There’s something about the project I was working on that’s not allowing it to register but I have no idea what. I’ve been using it for years and never had a problem.

I know how to use the plugin/how it’s supposed to work.

I thought it might be a bug that multiple people were experiencing. I’ll get around it not registering in that one project.

Appreciate you taking the time though, thanks.

Can’t quite work out whether you sorted your issue out. But please do take care here, it’s a good vibe and while we all have our quirks @jamieh goes to great lengths to help out users for little benefit. I don’t like anyone feeling uncomfortable around here.


Could you have accidentally dropped an instance of Scaler Audio onto a midi track instead?