MIDI velocity is being ignored in Ableton 11

When I change the velocity of single MIDI notes that correspond to chords in the sequencer of Scaler2’s MIDI track, the velocity of my VST’s output stays the same. I’m in session view and using Ableton’s sequencer to change the velocity. Am I doing something wrong?

My setup looks as follows:


MIDI From: All Ins, All Channels
Monitor: Auto
Audio To: Master
Arm Recording (Red button): On
Track Activator: Off


MIDI From: Scaler2, Scaler2
Monitor: In
Audio To: Master
Arm Recording (Red button): Off
Track Activator: On

I would appreciate it if someone could help me out. Thank you in advance!

It might be caused by my VST’s envelope settings, it seems to be working in other VSTs

Welcome to the forum @user8913918 Sounds like the VST you are using is not responding to velocity. Usual there’s a velocity sensitivity setting within the envelope section. Set at 0 it would not respond to velocity, set at full it would respond as per key press velocity.